Opened 22 months ago

Closed 22 months ago

#13367 closed Patch - Bug Fix (Works for me)

kDupCheckSubDesc duplicate detecting method fails, if either subtitle or description is empty

Reported by: Jarno Suni Owned by:
Priority: minor Milestone: 30.0
Component: MythTV - General Version: Unspecified
Severity: medium Keywords: Finnish EIT duplicate
Cc: Ticket locked: no

Description

On branch fixes/0.28. Seems to affect 29, too.

Two programs could be same, if e.g. both have empty subtitle and matching non-empty description. Currently, with kDupCheckSubDesc method, the check would tell the programs are different in such a case.

Attachments (1)

programinfo.cpp.patch (4.4 KB) - added by Jarno Suni 22 months ago.
the same changes are made in two methods: ProgramInfo::IsDuplicateProgram? and ProgramInfo::IsSameProgram?. The same code could be encapsulated better, I suppose.

Download all attachments as: .zip

Change History (2)

Changed 22 months ago by Jarno Suni

Attachment: programinfo.cpp.patch added

the same changes are made in two methods: ProgramInfo::IsDuplicateProgram? and ProgramInfo::IsSameProgram?. The same code could be encapsulated better, I suppose.

comment:1 Changed 22 months ago by gigem

Milestone: needs_triage30.0
Resolution: Works for me
Status: newclosed

kDupCheckSubDesc works exactly as intended. It should only be used in cases where you know both fields are non-empty. If you expect either field might be empty, you should use kDupCheckSubThenDesc instead.

Note: See TracTickets for help on using tickets.