Opened 10 months ago

Closed 10 months ago

Last modified 9 months ago

#13403 closed Bug Report - General (Invalid)

Watch TV fails after Myth Upgrade

Reported by: jaklug Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: v30-fixes
Severity: medium Keywords: watchtv fileringbuffer
Cc: Ticket locked: no

Description

I can record TV with MythTV, and I can watch TV with Caffeine.

I backed up my database, and restored first to .29, then to .30 with Ubuntu PPA, and neither work with WatchTV.

I tried increasing the signal timeouts to 3 and 10 seconds. The WatchTV fails in less than 1 second.

Frontend complains the buffer file is to small (0B). I tried increasing it with mythtv-setup and it is not 0 bytes. That did not help anyway.

The backend says something about expiring some program that I am not attempting to watch, though it is on the same channel I think.

Frontend:
Feb  6 22:18:19 tvscribe mythfrontend.real: mythfrontend[15692]: D CoreContext lcddevice.cpp:606 (switchToChannel) LCDdevice: switchToChannel
Feb  6 22:18:19 tvscribe mythfrontend.real: mythfrontend[15692]: I CoreContext videooutbase.cpp:1517 (DisplayOSD) VideoOutput: Created YV12 OSD.
Feb  6 22:18:19 tvscribe mythfrontend.real: mythfrontend[15692]: E CoreContext fileringbuffer.cpp:309 (OpenFile) FileRingBuf(/mnt/bigr0/store/2021_20190207041819.ts): OpenFile(): File too small (0B).

Backend:
Feb  6 22:18:18 tvscribe mythbackend: mythbackend[7290]: N CoreContext autoexpire.cpp:261 (CalcParams) AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
Feb  6 22:18:18 tvscribe mythbackend: mythbackend[7290]: N TVRecEvent recordinginfo.cpp:703 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: LiveTV to LiveTV (2)
Feb  6 22:18:19 tvscribe mythbackend: mythbackend[7290]: N CoreContext autoexpire.cpp:261 (CalcParams) AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
Feb  6 22:18:19 tvscribe mythbackend: mythbackend[7290]: N TVRecEvent recordinginfo.cpp:703 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: LiveTV to LiveTV (2)
Feb  6 22:18:19 tvscribe mythbackend: mythbackend[7290]: I TVRecEvent tv_rec.cpp:4261 (TuningNewRecorder) TVRec[9]: TuningNewRecorder - CreateRecorder()
Feb  6 22:18:19 tvscribe mythbackend: mythbackend[7290]: I TVRecEvent tv_rec.cpp:1091 (HandleStateChange) TVRec[9]: Changing from WatchingLiveTV to None
Feb  6 22:18:19 tvscribe mythbackend: mythbackend[7290]: N RecThread recorders/recorderbase.cpp:500 (FinishRecording) Finished Recording: Container: MPEG2-TS Video Codec: mpeg2video (0x0 A/R: 0 29.97fps) Audio Codec: ac3
Feb  6 22:18:19 tvscribe mythbackend: mythbackend[7290]: I TVRecEvent tv_rec.cpp:864 (FinishedRecording) TVRec[9]: FinishedRecording(2021_2019-02-07T04:18:19Z) damaged recq:<RecordingQuality overall_score="0" key="2021_2019-02-07T04:18:19Z">#012    <Gap start="2019-02-07T04:00:00Z" end="2019-02-07T04:30:00Z" duration="1800" />#012</RecordingQuality>
Feb  6 22:18:19 tvscribe mythbackend: mythbackend[7290]: I MythSocketThread(64) mainserver.cpp:7928 (connectionClosed) Playback sock(5636e615bd20) 'tvscribe' disconnected
Feb  6 22:18:24 tvscribe mythbackend: mythbackend[7290]: N Expire autoexpire.cpp:651 (SendDeleteMessages) Expiring 0 MB for 2021 at 2019-02-06T07:37:06Z => "Finding Your Roots With Henry Louis Gates, Jr.":"Freedom Tales"

The problem is 100% reproducible.

Attachments (2)

backend.log (4.4 KB) - added by jaklug 10 months ago.
/var/log/mythtv/mythbackend.log
frontend.log (5.5 KB) - added by jaklug 10 months ago.
/var/log/mythtv/mythfrontend.log

Download all attachments as: .zip

Change History (6)

Changed 10 months ago by jaklug

Attachment: backend.log added

/var/log/mythtv/mythbackend.log

Changed 10 months ago by jaklug

Attachment: frontend.log added

/var/log/mythtv/mythfrontend.log

comment:1 Changed 10 months ago by Peter Bennett

Please check your storage group for LiveTV. Perhaps it is set to an invalid directory.

comment:2 Changed 10 months ago by jaklug

The storage group setting was empty. Either it wasn't carried forward, or did not exist in my old level. Error handling could be more clear here.

Thanks.

comment:3 Changed 10 months ago by Peter Bennett

Resolution: Invalid
Status: newclosed

comment:4 Changed 9 months ago by Stuart Auchterlonie

Milestone: needs_triageunknown
Note: See TracTickets for help on using tickets.