Opened 10 months ago

Closed 3 months ago

Last modified 5 weeks ago

#13410 closed Bug Report - General (Duplicate)

MythTV does not update scheduled recordning titles and description from EPG

Reported by: bjoernv Owned by: Klaas de Waal
Priority: minor Milestone: 31.0
Component: MythTV - General Version: v29-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I observed the following behavior several times:

  • user schedules a recording with title "Film 1" from EPG
  • the TV channel changes the program and replaces the broadcast from "Film 1" to "Film 2"
  • MythTV starts recording at a the given time
  • recording gets the outdated metadata "Film 1" (title, description etc.)
  • user is confused because the content of the broadcast does not match the title

It would be more user-friendly, if the recording gets the new metadata from EPG. It would be even better, if MythTV could somehow log, that the broadcast has changed since recording time. But this may be difficult to implement.

Change History (5)

comment:1 Changed 10 months ago by gigem

Status: newinfoneeded_new

How are you getting your guide data? I'm guessing from EIT. If the channel changes its programming at the last minute or before MythTV has time to pick up the changes, there is nothing we can do about it. It is not practical for MythTV to continuously scan all channels for last minute changes like that. In such cases, MythTV will use whatever data it had at the time the recording was made.

comment:2 Changed 10 months ago by Klaas de Waal

Ticket #13057 describes the problem that title/subtitle/description from EIT are only updated when the new string is longer than the old string. Maybe this is also the problem here.

comment:3 Changed 9 months ago by Klaas de Waal

This ticket is most likely a duplicate of ticket #13057 which has been resolved today in master. The problems mentioned in this ticket should not occur anymore when using the latest master.

comment:4 Changed 3 months ago by Klaas de Waal

Resolution: Duplicate
Status: infoneeded_newclosed

In the current master, the guide data is updated as long as the recording has not yet started. This includes the title and the description. This is done in ticket #13057. This ticket is therefore closed as duplicate.

comment:5 Changed 5 weeks ago by Stuart Auchterlonie

Milestone: needs_triage31.0
Owner: set to Klaas de Waal
Note: See TracTickets for help on using tickets.