Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#13432 closed Bug Report - General (fixed)

mythtv-setup - second run of channel scan results in duplicate channels

Reported by: Mike Bibbings Owned by: Klaas de Waal
Priority: minor Milestone: 31.0
Component: MythTV - Channel Scanner Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Running mythtv-setup Input Connections scan for channels (Full scan) on DVB-T device (Astrometa usb) results in duplicate channels when a second scan is run. It seems that the original channels are not being recognised and the newly found channels are added instead of being updated.

Attachments: first-scan-mythtv-setup.20190320085633.3825.log

second-scan-mythtv-setup.20190320102218.7336.log

mythtv-setup-multiple-scan-results.txt - details mythtv-version and various tables channel,capturecard, dtv_multiplex

Attachments (8)

first-scan-mythtv-setup.20190320085633.3825.log (1.6 MB) - added by Mike Bibbings 9 months ago.
second-scan-mythtv-setup.20190320102218.7336.log (1.8 MB) - added by Mike Bibbings 9 months ago.
mythtv-setup-multiple-scan-results.txt (36.7 KB) - added by Mike Bibbings 9 months ago.
first-scan-t2-mythtv-setup.20190320111256.10060.log.tar.bz2 (127.2 KB) - added by Mike Bibbings 9 months ago.
second-scan-t2-mythtv-setup.20190320112358.10650.log.tar.bz2 (115.4 KB) - added by Mike Bibbings 9 months ago.
mythtv-setup-multiple-scan-results-t2.txt (37.4 KB) - added by Mike Bibbings 9 months ago.
dvb-t-scans-mythtv-setup.20190322103440.5235.log.tar.bz2 (152.9 KB) - added by Mike Bibbings 9 months ago.
dvb-t-scans-results.txt (37.0 KB) - added by Mike Bibbings 9 months ago.

Change History (18)

Changed 9 months ago by Mike Bibbings

Changed 9 months ago by Mike Bibbings

Changed 9 months ago by Mike Bibbings

comment:1 Changed 9 months ago by Mike Bibbings

Similar issue with TBS 6522 PCI-e DVB-T2 tuner, although in this case not all channels are duplicated.

Attachments:

first-scan-t2-mythtv-setup.20190320111256.10060.log.tar.bz2

second-scan-t2-mythtv-setup.20190320112358.10650.log.tar.bz2

mythtv-setup-multiple-scan-results-t2.txt - details mythtv-version and various tables channel,capturecard, dtv_multiplex

Changed 9 months ago by Mike Bibbings

Changed 9 months ago by Mike Bibbings

Changed 9 months ago by Mike Bibbings

comment:2 Changed 9 months ago by Mike Bibbings

Should have mentioned this is for current master. Can't change ticket header to show this.

Mike

comment:3 Changed 9 months ago by Klaas de Waal

Owner: set to Klaas de Waal
Status: newassigned
Version: UnspecifiedMaster Head

comment:4 Changed 9 months ago by Klaas de Waal

Problem can be reproduced now on DVB-T2 with a "Full Scan". A "Scan of all existing transports" is OK.

comment:5 Changed 9 months ago by Klaas de Waal <kdewaal@…>

Resolution: fixed
Status: assignedclosed

In b8141c84cb/mythtv:

Existing multiplexes not recognized with new DVB-T2 "Full Scan".

Doing a "Full Scan" with mythtv-setup for the first time the
channels are added and have the correct channel number.
The second run of "Full Scan" finds the same channels again
but sees them as new channels and they get the service ID number
because the correct channel number is already in use.
The third run gives conflicts on insertion because both
the correct channelnumber and the service id are already in use.

This problem is caused by the implementation of the
preliminary DVB-T2 support that has been added some time ago.
This creates some confusion whether a multiplex uses
the DVB-T or the DVB-T2 modulation system.
The strict comparison on the modulation system in
DTVMultiplex::IsEqual? even for the "fuzzy" type of
comparison makes that a new multiplex is not recognized
as already existing.

The solution for now is to treat the DVB-T and DVB-T modulation
systems as compatible when the "fuzzy" type of comparison is done.

Tickets #13014 and #12638 will comprise a more complete
implementation of DVB-T2 support.

Fixes #13432

comment:6 Changed 9 months ago by jpilk

Last week I went away with my DVB-T dongle and forgot to bring it back. So I got a MyGica? T230 and now have that working together with an old DVB-T-only pci card. I have DVB-T and DVB-T/T2 video sources, and what I believe to be complete scans, restricted to known muxes, with each. Only the local QPSK mux is seen twice. I seem to need active EIT for both cards.

At present for T2 I have to 'Prefer' the T2-capable card. While things are in a state of flux this seems worth mentioning; perhaps there's an existing solution.

F28, 31.Pre.224.g4a2be05

comment:7 in reply to:  5 Changed 9 months ago by Mike Bibbings

Replying to Klaas de Waal <kdewaal@…>:

In b8141c84cb/mythtv:

Existing multiplexes not recognized with new DVB-T2 "Full Scan".

Doing a "Full Scan" with mythtv-setup for the first time the
channels are added and have the correct channel number.
The second run of "Full Scan" finds the same channels again
but sees them as new channels and they get the service ID number
because the correct channel number is already in use.
The third run gives conflicts on insertion because both
the correct channelnumber and the service id are already in use.

This problem is caused by the implementation of the
preliminary DVB-T2 support that has been added some time ago.
This creates some confusion whether a multiplex uses
the DVB-T or the DVB-T2 modulation system.
The strict comparison on the modulation system in
DTVMultiplex::IsEqual? even for the "fuzzy" type of
comparison makes that a new multiplex is not recognized
as already existing.

The solution for now is to treat the DVB-T and DVB-T modulation
systems as compatible when the "fuzzy" type of comparison is done.

Tickets #13014 and #12638 will comprise a more complete
implementation of DVB-T2 support.

Fixes #13432

Confirmed as fixed for DVB-T/T2 capable tuner, not fixed for DVB-T only tuner.

I note that dtv_multiplex mod_sys is set to UNDEFINED, rather than DVB-T. For a DVB-T/T2 capable tuner mod_sys is set to either DVB-T or DVB-T2 as appropriate

Attachments:

dvb-t-scans-mythtv-setup.20190322103440.5235.log.tar.bz2

dvb-t-scans-results.txt

Changed 9 months ago by Mike Bibbings

Changed 9 months ago by Mike Bibbings

Attachment: dvb-t-scans-results.txt added

comment:8 Changed 9 months ago by Klaas de Waal <kdewaal@…>

In d0208428b/mythtv:

Set modulation system for DVB-T only tuner.

For DVB-T2 capable tuners dtv_multiplex/mod_sys is set to DVB-T
or DVB-T2 but this was not done for DVB-T only tuners.

Refs #13432

comment:9 Changed 9 months ago by Klaas de Waal

A fix to set the modulation system also for DVB-T tuners has been committed. As there is here only a DVB-T2 signal since two weeks this fix has not been tested other than that DVB-T2 still works.

About active EIT. Each video source needs its own EIT, although it should not need to be active.

About tuner preferences. Having two different video sources each with its own channels is not a problem. It becomes interesting when the same channel is available on both video sources; they will then appear in the guide as one channel and then it depends on tuner priorities/preferences which one will be used when that channel is selected.

comment:10 Changed 9 months ago by Stuart Auchterlonie

Milestone: needs_triage31.0
Note: See TracTickets for help on using tickets.