Opened 3 months ago

Closed 6 weeks ago

#13558 closed Bug Report - General (fixed)

VAAPI2 decoding of certain channel fails

Reported by: Jarno Suni Owned by: mark-kendall
Priority: minor Milestone: 31.0
Component: MythTV - General Version: v30-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythtv-frontend: 2:30.0+fixes.201912012038.a27754a~ubuntu19.10.1 By Standard decoder there is no such an issue. This happens only with one channel in my experience, not with other channels from the same DVB-T multiplex.

Attachments (1)

Screenshot_2020-01-14_12-58-26.png (1.3 MB) - added by Jarno Suni 3 months ago.
screenshot in VAAPI2 playback

Download all attachments as: .zip

Change History (8)

Changed 3 months ago by Jarno Suni

screenshot in VAAPI2 playback

comment:1 Changed 3 months ago by mark-kendall

Status: newinfoneeded_new

Can you provide a small (30-60 second) clip that demonstrates the problem.

comment:2 Changed 3 months ago by Jarno Suni

comment:3 Changed 3 months ago by mark-kendall

Milestone: needs_triage31.0
Owner: set to mark-kendall
Status: infoneeded_newassigned

comment:4 Changed 3 months ago by mark-kendall

This looks like either an FFmpeg or driver issue. Video is broken up with MythTV master but no errors are produced by FFmpeg.

ffmpeg (the command line utility) has the same problem. vlc just crashes and VAAPI is disabled for MPEG2 with mpv.

comment:5 Changed 7 weeks ago by Mark Kendall <mark.kendall@…>

In 28d6cc12f9/mythtv:

VAAPI: Fix corrupt MPEG2 decoding

comment:6 Changed 7 weeks ago by Mark Kendall <mark.kendall@…>

In 05c401f9d6/mythtv:

VAAPI: Fix corrupt MPEG2 decoding

comment:7 Changed 6 weeks ago by Mark Kendall <mark.kendall@…>

Resolution: fixed
Status: assignedclosed

In ab250d6ccf/mythtv:

VAAPI2: Fix corrupt MPEG2 decoding

Note: See TracTickets for help on using tickets.