Opened 10 months ago

Closed 9 months ago

#13560 closed Bug Report - General (Fixed)

Aspect ratio wrong on dual-screen system

Reported by: jpilk Owned by: Mark Kendall
Priority: minor Milestone: 31.0
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Commits today were linked to this but the problem persists. I gave background in #13548. Size, shape, placement is good on the TV but the in the window on the monitor the video is around 90% of the expected height. Here are links to screenshots and logs with -v playback both without and with -display=HPFed:0.0

https://drive.google.com/open?id=1psskr9EBIHbmRLr9aaK8XcuhWHXv7xfQ

Change History (4)

comment:1 Changed 10 months ago by Mark Kendall

Owner: set to Mark Kendall
Status: newaccepted

comment:2 Changed 9 months ago by jpilk

Thank you! I have aeb97c5 installed on two F30 twin-screen systems with nVidia GT 710 cards and 440.46 rpmfusion drivers.

On both systems the default windowed display on the monitor (as defined in Frontend > Setup > Appearance), and the unwindowed display with -geometry override on the TV, now give playback with the intended placement and geometry.

The TV is 1920x1080, as is one of the monitors. The other monitor, which had the problem in the tests above, is 1680x1050.

It looks fixed to me.

comment:3 Changed 9 months ago by Mark Kendall <mark.kendall@…>

In aeb97c5d2e/mythtv:

MythVideoOutput?: Fix a regression with windowed aspect ratio

Refs #13548
Refs #13560

comment:4 Changed 9 months ago by Mark Kendall

Component: MythTV - GeneralMythTV - Video Playback
Milestone: needs_triage31.0
Resolution: Fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.