Opened 5 months ago

Closed 4 months ago

#13566 closed Bug Report - General (Duplicate)

Extra child window in mythfrontend that sometimes covers part of gui

Reported by: thebitpit Owned by:
Priority: minor Milestone: 31.0
Component: MythTV - General Version: v30-fixes
Severity: medium Keywords: mythfrontend
Cc: Ticket locked: no

Description

Starting mythfrontend everything looks right and functions properly. Entering into a frontend setup gui, among other things, causes a white window to appear on top of part of the gui. This window does not capture any input events and obscures part of the gui. All input events pass through to the window under it. This white window is never visible when video is displayed. It usually appears when the video ends or is stopped and a gui is shown.

The problem exists with both intel and nvidia video cards.

Run the xwininfo -tree command in an xterm and click the mouse anywhere in the mythtv gui; On the white window or outside it gives the same result:

# xwininfo -tree

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0xb200006 "MythTV Frontend"

  Root window id: 0x13a (the root window) (has no name)
  Parent window id: 0x280044c (has no name)
     1 child:
     0xb200025 "mythfrontend": ("mythfrontend.real" "mythfrontend")  3840x2160+0+0  +0+0
        1 child:
        0xb200031 "mythfrontend": ("mythfrontend.real" "mythfrontend")  2448x968+40+40  +40+40

The child window with size/offset 2448x968+40+40 is exactly the blank white window that is obscuring the gui. On a 1920x1080 monitor the window size changes but the same percentage of the screen obscured.

It can be hidden by reloading the the theme. The size changes with the theme selected.

There is an extra child window in mythtv-setup too. It is not usually visible as a white window:

# xwininfo -tree

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0xb200006 "MythTV Setup"

  Root window id: 0x13a (the root window) (has no name)
  Parent window id: 0x2800467 (has no name)
     1 child:
     0xb200025 "mythtv-setup": ("mythtv-setup" "mythtv-setup")  3840x2160+0+0  +0+0
        1 child:
        0xb200031 "mythtv-setup": ("mythtv-setup" "mythtv-setup")  3283x1742+0+0  +0+0

Does an extra child window appear on the Mythtv Master branch?

Is this a residual MythContextPrivate::TempMainWindow() that is not being destroyed? Is it an extra MythMainWindow()?

I'm a retired software developer, but I am reluctant to test on the master branch because it usually has changes to the database and my only system is my production system.

I did find one possible error and the attached patch does not fix the problem.

Attachments (1)

mythtv-30.0_p20190808-Fix_EndTempWindow.patch (204 bytes) - added by thebitpit 5 months ago.

Download all attachments as: .zip

Change History (5)

Changed 5 months ago by thebitpit

comment:1 Changed 4 months ago by paul-h

comment:2 Changed 4 months ago by thebitpit

Yes I am using Qt 5.14 on gentoo. Everything is compiled from source code.

comment:3 Changed 4 months ago by thebitpit

Please make this bug a duplicate of https://code.mythtv.org/trac/ticket/13544 and close it

comment:4 Changed 4 months ago by Bill Meek

Milestone: needs_triage31.0
Resolution: Duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.