Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#13602 closed Bug Report - General (Fixed)

Fails to record HD channels and watch them

Reported by: Jarno Suni Owned by:
Priority: blocker Milestone: unknown
Component: MythTV - Recording Version: v31-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

Format: DVB-T2 AVC (PAL 50 Hz, Finland)

Playback tells it can not do channel lock after a while when I start live TV playback. This is only on HD channels. This is regression from version 30.

If I schedule recording, there will be an item in "Watch Recordings" list by small letters, but the recording is unavailable, if I try to play it.

SD TV recording/watching seems to work fine.

Attachments (1)

ms-20200403-1256.log (5.6 KB) - added by Jarno Suni 10 months ago.
taskset -c 0 /usr/bin/mythtv-setup.real --syslog local7 -v chanscan 2>&1 | tee ms-20200403-1256.log

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 months ago by Jarno Suni

If you need any logs, please tell me soon. I may downgrade soon to be able to use MythTV.

comment:2 Changed 10 months ago by Klaas de Waal

If you have not done that yet you could try to do a new channelscan. This can be done in three variations, from routine to new installation:

  • do a full scan and update the old channels
  • delete all channels and do a full scan
  • create a new videosource and do a full scan

Please try the variations in the order given and after each scan, see if that makes a difference.

comment:3 Changed 10 months ago by Jarno Suni

Ok, I tried the first one. How do you change the language for the setup BTW? Tuning method (the second last item in channel search dialog) tells opening card failed. Anyway, I ran search (the last item), and I get an error dialog: Mistake of coder, see console. Nothing on console. Should I try the other ones now?

comment:4 Changed 10 months ago by Klaas de Waal

Language setup is done with mythfrontend when mythbackend is running. Same is true for theme selection.

All channelscans should do something, a failure on opening the card usually suggests that the backend is still running. The "Mistake of coder" type of messages should never happen and are thus most interesting.

Please do a scan like this: "mythtv-setup -v chanscan 2>&1 | tee ms-20200403-1256.log" and attach the log file to the ticket.

comment:5 Changed 10 months ago by Jarno Suni

Backend was not running. There is nothing in the log/console.

comment:6 Changed 10 months ago by Klaas de Waal

Please run mythtv-setup in a console / terminal window. There is always some output and much more so with the -v chanscan option. If you can start mythtv-setup and there is no output at all then there must be something wrong with the system. Try e.g. "ls -la" in that terminal window and see if that shows some output.

comment:7 Changed 10 months ago by Bill Meek

@Jarno, some distributions use a wrapper script that ends up calling mythtv-setup.real. I'd run that with the options Klaas recommends. Use: locate mythtv-setup to find it if it isn't in your PATH.

comment:8 Changed 10 months ago by Jarno Suni

The cause of this issue was that the HD channels were actually gone and part of them are now available via another provider and multiplex. This happened about the same time as my upgrade to MythTV 31, so I thought it was because of that.

comment:9 Changed 10 months ago by Jarno Suni

As for what was causing failing of the scan, there was some permission problem concerning the adapters. If I log in to the xubuntu-desktop session of the separate backend server locally, the permission problem does not appear, even if I use mythtv-setup remotely via ssh -X like I did before.

Changed 10 months ago by Jarno Suni

Attachment: ms-20200403-1256.log added

taskset -c 0 /usr/bin/mythtv-setup.real --syslog local7 -v chanscan 2>&1 | tee ms-20200403-1256.log

comment:10 Changed 10 months ago by Klaas de Waal

The log shows a "permission denied" problem. When you can get mythtv-setup to run as the same user as what is used for the backend (usually "mythtv") then you should not have that. After doing a Full Scan it could be that everything is working again.

comment:11 Changed 10 months ago by Klaas de Waal

Is this problem solved now? Then we can close the ticket.

comment:12 Changed 10 months ago by Jarno Suni

As for the original problem, yes. But as for the permission problem, no; I want to be able to run mythtv-setup remotely. If I run mythtv-setup locally then even if $USER is different than mythtv, there is no such permission problem.

comment:13 Changed 9 months ago by Klaas de Waal

Resolution: Fixed
Status: newclosed

Closing this ticket now as the problem is solved. For the permission issue, if that is still a problem, then possibly the mailing list or the forum is a good place to discuss it.

If the permission issue is a bug in mythtv-setup then please create a new ticket.

comment:14 Changed 9 months ago by Stuart Auchterlonie

Milestone: needs_triageunknown
Note: See TracTickets for help on using tickets.