Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#13640 closed Bug Report - General (fixed)

Transort Editor does not work on Slave Backend

Reported by: jksj461 Owned by: Klaas de Waal
Priority: minor Milestone: 31.1
Component: MythTV - General Version: v31-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Attempting to delete a UK DVB-T2 transport on a slave backend fails with

2020-06-22 18:01:55.499970 E CardUtil?: Can't open DVB frontend (/dev/dvb/adapter0/frontend0) for /dev/dvb/adapter0/frontend0.

The slave backend was not running and a full scan of all channels worked fine, so the issue only involves the transport editor.

pi@PiSlave:~ $ mythtv-setup 
libEGL warning: DRI2: failed to authenticate
"Display: Requesting EGL for 'Mesa Project, 1.4'"
libEGL warning: DRI2: failed to authenticate
qt5ct: using qt5ct plugin
2020-06-22 17:59:42.805880 I  Setup Interrupt handler
2020-06-22 17:59:42.806037 I  Setup Terminated handler
2020-06-22 17:59:42.806069 I  Setup Segmentation fault handler
2020-06-22 17:59:42.806097 I  Setup Aborted handler
2020-06-22 17:59:42.806126 I  Setup Bus error handler
2020-06-22 17:59:42.806155 I  Setup Floating point exception handler
2020-06-22 17:59:42.806184 I  Setup Illegal instruction handler
2020-06-22 17:59:42.806231 I  Setup Real-time signal 0 handler
2020-06-22 17:59:42.806263 I  Setup Hangup handler
2020-06-22 17:59:42.806711 C  mythtv-setup version: fixes/31 [v31.0-40-gce23a0225f] www.mythtv.org
2020-06-22 17:59:42.806741 C  Qt version: compile: 5.11.3, runtime: 5.11.3
2020-06-22 17:59:42.806928 I  Raspbian GNU/Linux 10 (buster) (arm)
2020-06-22 17:59:42.806939 N  Enabled verbose msgs:  general
2020-06-22 17:59:42.807005 N  Setting Log Level to LOG_INFO
2020-06-22 17:59:42.817948 I  Added logging to the console
2020-06-22 17:59:42.975445 N  Using runtime prefix = /usr/local
2020-06-22 17:59:42.975470 N  Using configuration directory = /home/pi/.mythtv
2020-06-22 17:59:42.975620 I  Assumed character encoding: en_GB.UTF-8
2020-06-22 17:59:42.994432 I  Loading en_gb translation for module mythfrontend
2020-06-22 17:59:43.009060 I  Empty LocalHostName. This is typical.
2020-06-22 17:59:43.009102 I  Using a profile name of: 'PiSlave' (Usually the same as this host's name.)
2020-06-22 17:59:43.009384 I  Start up testing connections. DB 192.168.0.108, BE , attempt 0, status dbAwake, Delay: 2000
2020-06-22 17:59:43.557089 N  Setting QT default locale to en_GB
2020-06-22 17:59:43.557210 I  Current locale en_GB
2020-06-22 17:59:43.557578 N  Reading locale defaults from /usr/local/share/mythtv//locales/en_gb.xml
2020-06-22 17:59:43.602984 I  Display: Defaulting to primary screen (default)
2020-06-22 17:59:43.603219 I  Display: Using screen 'default' (Make: Unknown Model: Unknown)
2020-06-22 17:59:43.603387 I  Display: Geometry: 1920x1080+0+0 Size(Qt): 508mmx286mm
2020-06-22 17:59:43.619170 N  Display: Desktop video mode: 1920x1080 60.000Hz
2020-06-22 17:59:43.662056 I  Starting process manager
2020-06-22 17:59:43.662080 I  Starting process signal handler
2020-06-22 17:59:43.662478 I  Starting IO manager (read)
2020-06-22 17:59:43.662502 I  Starting IO manager (write)
2020-06-22 17:59:43.713645 I  ScreenSaverX11Private: DPMS is active.
2020-06-22 17:59:43.832612 E  PowerDBus: No UPower interface. Unable to monitor battery state
2020-06-22 17:59:43.869443 I  Power: On AC power
2020-06-22 17:59:43.869557 I  Power: Supported actions: Restart,Shutdown
2020-06-22 17:59:43.910856 I  Loading en_gb translation for module mythfrontend
2020-06-22 17:59:43.924211 E  LIRC: Failed to connect to Unix socket '/var/run/lirc/lircd'
			eno: No such file or directory (2)
2020-06-22 17:59:43.924381 I  No joystick configuration found, not enabling joystick control
2020-06-22 17:59:43.924400 I  UDPListener: Enabling
2020-06-22 17:59:43.933188 I  Binding to UDP 0.0.0.0:0
2020-06-22 17:59:43.936156 I  Binding to UDP [::]:0
2020-06-22 17:59:44.039227 I  Using Frameless Window
2020-06-22 17:59:44.039246 I  Using Full Screen Window
2020-06-22 17:59:44.056969 I  Display: Have main widget
2020-06-22 17:59:44.056991 I  Display: Have main window
2020-06-22 17:59:44.059114 I  Display: Defaulting to primary screen (default)
2020-06-22 17:59:44.065118 I  UI Screen Resolution: 1920 x 1080
QOpenGLFramebufferObject: Framebuffer incomplete attachment.
QOpenGLFramebufferObject: Framebuffer incomplete, missing attachment.
2020-06-22 17:59:44.368471 E  Failed to create framebuffer object
2020-06-22 17:59:44.368958 I  OpenGL: OpenGL vendor        : VMware, Inc.
2020-06-22 17:59:44.369000 I  OpenGL: OpenGL renderer      : llvmpipe (LLVM 9.0.1, 128 bits)
2020-06-22 17:59:44.369036 I  OpenGL: OpenGL version       : OpenGL ES 3.1 Mesa 19.3.2
2020-06-22 17:59:44.369095 I  OpenGL: Qt platform          : xcb
2020-06-22 17:59:44.369354 I  OpenGL: EGL display          : Yes
2020-06-22 17:59:44.369390 I  OpenGL: EGL images           : Yes
2020-06-22 17:59:44.369419 I  OpenGL: Qt OpenGL format     : OpenGLES 3.1
2020-06-22 17:59:44.369448 I  OpenGL: Qt OpenGL surface    : RGBA: 8880 Depth: 0 Stencil: 0
2020-06-22 17:59:44.369481 I  OpenGL: Max texture size     : 8192
2020-06-22 17:59:44.369514 I  OpenGL: Max texture units    : 128
2020-06-22 17:59:44.369547 I  OpenGL: Shaders              : Yes
2020-06-22 17:59:44.369576 I  OpenGL: NPOT textures        : Yes
2020-06-22 17:59:44.369605 I  OpenGL: Multitexturing       : Yes
2020-06-22 17:59:44.369634 I  OpenGL: Rectangular textures : No
2020-06-22 17:59:44.369663 I  OpenGL: Buffer mapping       : Yes
2020-06-22 17:59:44.369693 I  OpenGL: Framebuffer objects  : Yes
2020-06-22 17:59:44.369724 I  OpenGL: 16bit framebuffers   : No
2020-06-22 17:59:44.369754 I  OpenGL: Unpack Subimage      : Yes
2020-06-22 17:59:44.369784 I  OpenGL: GL_RED/GL_R8         : Yes
2020-06-22 17:59:44.476480 I  OpenGL: Initialised MythRenderOpenGL
2020-06-22 17:59:44.476510 I  OpenGL: Using full range output
2020-06-22 17:59:44.486492 I  MythUIHelper: Pruning cache directory: /home/pi/.mythtv/cache/remotecache
2020-06-22 17:59:44.488075 I  MythUIHelper: Kept 0 files, deleted 0 files, stat error on 0 files
2020-06-22 17:59:44.488176 I  MythUIHelper: Pruning cache directory: /home/pi/.mythtv/cache/thumbnails
2020-06-22 17:59:44.489566 I  MythUIHelper: Kept 0 files, deleted 0 files, stat error on 0 files
2020-06-22 17:59:45.615246 I  CECAdapter: Found 1 CEC devices(s).
2020-06-22 17:59:45.615382 I  CECAdapter: Device 1: path 'Raspberry Pi' com port 'RPI' SELECTED
2020-06-22 17:59:45.615422 I  CECAdapter: Trying to open device Raspberry Pi (RPI).
2020-06-22 17:59:45.616144 I  CECAdapter: connection opened
2020-06-22 17:59:45.881125 I  CECAdapter: registering new CEC client - v4.0.4
2020-06-22 17:59:46.572732 I  CECAdapter: >> source activated: Playback 1 (4)
2020-06-22 17:59:46.572838 I  CECAdapter: Source 4 Activated
2020-06-22 17:59:46.573076 I  CECAdapter: CEC client registered: libCEC version = 4.0.4, client version = 4.0.4, firmware version = 1, logical address(es) = Playback 1 (4) , physical address: 1.0.0.0, compiled on Linux-4.15.0-48-generic ... , features: P8_USB, DRM, P8_detect, randr, RPi, Exynos, AOCEC
2020-06-22 17:59:47.205063 I  CECAdapter: << powering on 'TV' (0)
2020-06-22 17:59:47.355943 I  CECAdapter: << Playback 1 (4) -> broadcast (F): active source (1000)
2020-06-22 17:59:47.808922 I  CECAdapter: Opened CEC device.
2020-06-22 17:59:47.809239 I  CECAdapter: << powering on 'TV' (0)
2020-06-22 17:59:47.870014 I  CECAdapter: Asked TV to turn on.
2020-06-22 17:59:47.931376 I  CECAdapter: >> source activated: Playback 1 (4)
2020-06-22 17:59:47.931488 I  CECAdapter: Source 4 Activated
2020-06-22 17:59:47.931600 I  CECAdapter: << powering on 'TV' (0)
2020-06-22 17:59:47.991908 I  CECAdapter: << Playback 1 (4) -> broadcast (F): active source (1000)
2020-06-22 17:59:48.413587 I  CECAdapter: Asked TV to switch to this input.
2020-06-22 17:59:48.433638 I  Current MythTV Schema Version (DBSchemaVer): 1361
2020-06-22 18:01:55.490674 I  CardUtil[22]: Set delivery system: DVB-T2
2020-06-22 18:01:55.499970 E  CardUtil: Can't open DVB frontend (/dev/dvb/adapter0/frontend0) for /dev/dvb/adapter0/frontend0.
			eno: Device or resource busy (16)
2020-06-22 18:03:07.316046 I  CardUtil[22]: Set delivery system: DVB-T2
2020-06-22 18:03:07.322236 I  CardUtil[22]: Set delivery system: DVB-T2
2020-06-22 18:03:37.708992 I  CardUtil[22]: Set delivery system: DVB-T2

Scan parameters:
Desired Services            : tv
Unencrypted Only            : yes
Logical Channel Numbers only: no
Complete scan data required : yes
Full search for old channels: yes
Remove duplicate channels   : yes
2020-06-22 18:05:08.958596 C  'SignalMonitor': MThread prolog was never run!

Channel list (10):
auto:474000000:Liverpool TV:7:12330:9018:32840:32776=32776:dvb
auto:474000000:Tiny Pop:207:12330:9018:33472:32776=32776:dvb

Attachments (1)

debug.txt (413.6 KB) - added by jksj461 4 months ago.
Log

Download all attachments as: .zip

Change History (10)

comment:1 Changed 4 months ago by Klaas de Waal

Owner: set to Klaas de Waal
Status: newassigned

comment:2 Changed 4 months ago by jksj461

Info the master backend hosts Freesat tuners and the slave Freeview.

A further attempt shows that with both the master and slave backends stopped. The Transport Editor on the slave is entered showing a screen with

Video Sourece Freeview --correct

{New Transport)

Blank list

On the master backend the Transport Editor works for a source which has tuners resident ie Freesat but responds with No capture card! Connect video source 'Freeview' to a capture card in the 'Input Connections' menu page.

comment:3 Changed 4 months ago by Klaas de Waal

A check with the current v32-pre software version and with a newly created RPI slave backend shows the following behavior when running mythtv-setup:

  • On both master and slave backends the "Video Sources" shows the same list of all video sources.
  • On both master and slave backends the Transport Editor can only be used for a video source that is connected to a capture card on that system.

So on the slave backend one should see all video sources but only the transports of the video source connected to a capture card on that backend can be edited.

As reported, the capture card on the slave backend can be used to do a channelscan. This shows that the capture card is connected to the video source. The problem is, as I understand it, that it is NOT possible to use the Channel Editor on that video source on the slave backend.

There have not been that many changes in this part of the software since v31 and none that I can directly relate to this.

The message in the log:

CardUtil: Can't open DVB frontend (/dev/dvb/adapter0/frontend0) for /dev/dvb/adapter0/frontend0.
			eno: Device or resource busy (16)

is what you get when mythtv-setup is started while mythbackend is running. Please make sure that this is not the case here.

To investigate this further, a log created as follows:

mythtv-setup -v general,channel,record,chanscan,database --loglevel=debug 2>&1 | tee ms-20200623-2245.log

when trying to start the Channel Editor might be useful.

Changed 4 months ago by jksj461

Attachment: debug.txt added

Log

comment:4 Changed 4 months ago by jksj461

The result was as before log attached above. The log shows the transports are visible but I still get a blank list which smacks of using the HCI wrongly. Will check again using the editor on master. Can't get access again until tomorrow. Clearly a low priority issue which can be worked round by temporarily connecting a slave tuner on master.

comment:5 Changed 4 months ago by jksj461

Just tried it. On master the transport editor works perfectly for Freesat the source connected to that machine. So mystified!

comment:6 Changed 4 months ago by Klaas de Waal

I think that I have found it. It is most likely something that I fixed in master recently as part of commit fcf9e8e79fd4971d298cd8c3a53466d256f7f0ff:

Fixed a problem where sometimes the Transport Editor did not show any
transports when there were only a small number of transports in the video source.

I'll have a go at backporting it to v31.

comment:7 Changed 4 months ago by Klaas de Waal <kdewaal@…>

Resolution: fixed
Status: assignedclosed

In b89d76fa94/mythtv:

Transport Editor updates

Show the DVB-C parameter edit page for HDHomeRun tuners when they can do DVB-C.
Previously the ATSC parameter edit page was shown.
Show the DVB-T2 parameter edit page for HDHomeRun tuners when they can do other DVB.
Previously the ATSC parameter edit page was shown.
Fixed a problem where sometimes the Transport Editor did not show any
transports when there were only a small number of transports in the video source.
FIxed a problem where the modulation system was not saved in the transport when a
DVB-S (not a DVB-S2) tuner and the transports came from the NIT transport loop.

(cherry picked from commit fcf9e8e79fd4971d298cd8c3a53466d256f7f0ff)

Fixes #13640

Signed-off-by: Klaas de Waal <kdewaal@…>

comment:8 Changed 4 months ago by jksj461

Many thanks works fine. Successfully cleaned up transports and rescanned.

comment:9 Changed 4 months ago by Stuart Auchterlonie

Milestone: needs_triage31.1
Note: See TracTickets for help on using tickets.