Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1369 closed defect (fixed)

Preview thumbnail for all recorded programs is distorted (colors)

Reported by: kmp589@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: 0.19
Severity: low Keywords:
Cc: makomk@… Ticket locked: no

Description

In the "Watch Recordings" menu, the preview thumbnail for the recorded videos is distorted. The colors are distorted and there is a cyan/green line on the bottom of the frame.

This may be already discussed in changeset 8895, but I'm not certain if changeset 8895 is referencing to this particular problem.

I am currently running myth 0.19-20060121-2.

Screenshot: http://i14.photobucket.com/albums/a340/kmp589/screenshot_preview_broken.jpg

Change History (9)

comment:1 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk

What are the resolutions of the video and of the mythfrontend?

I believe this is due to using an improper resolution in the preview scaler which breaks the RGB->YUV conversion (which only allows certain resolutions due to the way planar YUV works).

comment:2 Changed 14 years ago by kmp589@…

The resolution of the recorded video is 540x480. Mythfrontend I believe is either 800x600 or 1024x780 (I'm leaning towards the latter).

comment:3 Changed 14 years ago by kmp589@…

I mistyped - it should be 1024x768.

comment:4 Changed 14 years ago by danielk

Resolution: wontfix
Status: newclosed

How did you end up with a recorded resolution of 540x480 ?

540 is not evenly divisible by 8 much less 16...

I think the problem is in the config that let you set up this recording resolution.

If this is still allowed by 0.19-fixes or svn-head please open a ticket on the config problem.

comment:5 Changed 14 years ago by Aidan Thornton <makomk@…>

Cc: makomk@… added
Resolution: wontfix
Status: closedreopened

I'm getting exactly the same problem here, both on my older 480x480 recordings and my newer 720x576 ones. Again, this is on 0.19-fixes (though I also had this with 0.19 and IIRC possibly even 0.18.1). I'm using MPEG-4 software encoding, screen/mythfrontend resolution is 1024x768, no idea what resolution the video is being displayed at in the preview window.

comment:6 Changed 14 years ago by danielk

Are you guys talking about the preview video?

I don't see any way that the preview image could be messed up with a 720x576 video.

comment:7 Changed 14 years ago by anonymous

Oops, sorry - yes, my problem was with the preview video, not the thumbnails. Same sort of mangled colours as the original reporter, but I think his problem was with the thumbnails...

comment:8 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [9578]) Closes #1369, avoids preview video chroma problem by restricting resolution more strictly.

comment:9 Changed 14 years ago by danielk

(In [9579]) Refs #1369. Avoids preview video chroma problem in 0.19-fixes by restricting resolution more strictly.

Note: See TracTickets for help on using tickets.