Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1394 closed defect (fixed)

High CPU consumption recording MJPEG

Reported by: nonymouse Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If I use lavrec (mjpegtools) to record a program from my Matrox G400 I get less than 1% cpu usage. However when I record using Mythtv the cpu consumption goes up to over 90%.

Why would that be? Surely MythTV would/should simply transfer the MJPEG frames into the container of its choice (ie. NuppelVideo?), and only perform a conversion if absolutely necessary. There is often absolutely no need to convert from MJPEG to anything in software for playback either (when using lavplay for example).

And why isn't there a simple configuration file which can be used to set up relevent command lines for various activities (like recording, playback, etc)?

And why isn't a simple, well supported, video format like avi used (or an extension of it)? If the issue is timecode then avi can handle it in a compatible manner.

Change History (3)

comment:1 Changed 14 years ago by Dibblah

Resolution: invalid
Status: newclosed

This is not a discussion forum. Please post development related questions to the appropriate mailing list.

Once you have a patch to fix this issue or a commit number when the issue started to occur, please feel free to reopen this ticket.

comment:2 Changed 14 years ago by danielk

Resolution: invalidfixed

(In [9328]) Fixes #1394. The patch was incorrect but pointed me toward the broken code.

comment:3 Changed 14 years ago by danielk

Sorry, the message last commit should have referenced #1392.

Note: See TracTickets for help on using tickets.