Opened 13 years ago

Closed 13 years ago

#1401 closed defect (fixed)

Fix bad URL in contrib/osx-packager.pl

Reported by: ask@… Owned by: Nigel
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

osx-packager.pl tries downloading a version of MySQL that's not on the mirrors anymore.

This fixes it:

Index: contrib/osx-packager.pl =================================================================== --- contrib/osx-packager.pl (revision 9155) +++ contrib/osx-packager.pl (working copy) @@ -116,7 +116,7 @@

=> {

'url'

+ => 'http://mysql.binarycompass.org/Downloads/MySQL-4.1/mysql-4.1.16.tar.gz',

'conf' => [

'--without-debug',

Change History (7)

comment:1 Changed 13 years ago by anonymous

Owner: changed from Isaac Richards to anonymous
Status: newassigned

comment:2 Changed 13 years ago by Nigel

Owner: changed from anonymous to Nigel
Status: assignednew

comment:3 Changed 13 years ago by Nigel

Status: newassigned

comment:4 Changed 13 years ago by Nigel

1) Thanks for the bug report. Yes, this needs fixing
2) A quick look at http://dev.mysql.com/downloads/mysql/4.1.html tells me that 4.1.18 is the latest and greatest. I will use thr mirror you suggest, but promote to this latest version to try and stay ahead of mirror ageing
3) Need to do a quick test build first...

comment:5 Changed 13 years ago by ask@…

Hi Nigel,

Yeah, I didn't look carefully enough obviously. :-)

Thanks for fixing it!

By the way, why not use the mysql client lib from 5.0.x?

  • ask

comment:6 Changed 13 years ago by Nigel

Not sure about backwards compatibility between 5.0 libs and 4.1 databases, so I will leave it at 4.0.18 for now

comment:7 Changed 13 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [9165]) Closes #1401

Note: See TracTickets for help on using tickets.