Opened 14 years ago

Closed 14 years ago

#1490 closed task (fixed)

Need a popup dialog to tell the user why they can't edit when they don't have a seektable.

Reported by: xris Owned by: cpinkham
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I think this is likely related to #1315.. I was playing aroundin the db and wiped my recordedmarkup table clean, only to discover that I could no longer to and edit programs. Pressing E did nothing, as did M and then selecting "Edit" from the menu. Silently failing (nothing printed to the console, even) when there is no seek table is probably bad -- I'm guessing that a user will run into this someday with a corrupted recordedmarkup table, and it would be nice to have a meaningful error message of some sort.

I fixed the problem by rerunning mythcommflag with the --rebuild option. Once the seek table was back in place, everything worked again.

Change History (4)

comment:1 Changed 14 years ago by stuart@…

I don't believe this is related to #1315. As far as I can tell editing has been permitted on recordings without a positionmap (seek table) for a long time, if ever.

You should be seeing an error though: VERBOSE(VB_IMPORTANT, "Cannot edit - no full position map");

I'm having a little trouble following the code at this point. Essentially editing depends on hasFullPositionMap being true. hasFullPositionMap depends on the return value of GetDecoder?()->OpenFile? being true. However I've yet to work out what function GetDecoder?()->OpenFile? is actually calling, thus which return values it might return etc

comment:2 Changed 14 years ago by cpinkham

Owner: changed from Isaac Richards to cpinkham
Summary: Edit mode doesn't work after wiping recordedmarkupNeed a popup dialog to tell the user why they can't edit when they don't have a seektable.
Type: defecttask

We don't allow editting if a recording does not have a seektable because jumping around in the editor would be very very slow since we would have to seek frame by frame. I assume these were MPEG-2 recordings and not nuppel .nuv recordings. I'm going to change the summary of this and accept the ticket as a bug and I'll add a popup dialog to warn the user why they can't edit.

comment:3 Changed 14 years ago by anonymous

I just expierenced this when my BE crashed silently yesterday and I found today that I can't edit recording. The SQL table was a little bit broken.

At least with [9363] and 'mythbackend -v record' I got message from BE that I should run 'mythcommflag' with --rebuild for that recording. FE also logged that full position map missing. After that everything worked fine again.

Of course would be great to see it from in GUI but anyway you have to ckeck logs when "strange" things happen.

comment:4 Changed 14 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [9394]) Display a simple OSD message telling the user if there is no seektable when they try to edit a recording. Previously there was no indication why they oculd not enter edit mode. Closes #1490.

Later I want to add a way for the player to trigger a seektable rebuild in cases like this or when we start playing a recording with no seektable, but that is not covered by the scope of this ticket.

Note: See TracTickets for help on using tickets.