Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1499 closed defect (invalid)

Myth fails to detect DVD insertion

Reported by: raptorjr Owned by: ijr
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

When inserting a DVD, Myth is looking for a VIDEO_TS folder to launch the right handler. But this comparision is not case insensitive. If the DVD contains a video_ts folder Myth fails to detect that it is a DVD that was inserted.

I tried to change the #define PATHTO_DVD_DETECT "/VIDEO_TS" in mythcdrom.cpp to "/video_ts". And now my DVDs get detected. Someone a little more in to programming could probably make the changes so that Myth makes a case insensitive comparison instead. So both VIDEO_TS and video_ts DVDs get detected.

Attachments (0)

Change History (8)

comment:1 Changed 12 years ago by cpinkham

  • Resolution set to invalid
  • Status changed from new to closed

This is not a bug, either your DVD is not a valid DVD, or your mount options for the DVD are mounting it as a iso9660 instead of udf. This should have been asked on the -users mailing list first and someone would have given you the answer, it is also covered in the documentation I believe.

comment:2 Changed 12 years ago by anonymous

And if you read the -users mailinglist you will notice that i did ask and never got a answer. And it is not in the MythDVD section of the documentation. And i didn't find anything useful searching the mailinglist. Please dont assume that everyone is lazy and submits a ticket the first thing they do. I just try to help and everytime i get my a kicked for it.

comment:3 Changed 12 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

For some of us this is not a simple task, because we use hal/submount. This is standard in some distos like SuSe? 10.0.

If you insert an Video-DVD the filetype cdfss is choosen. That means submount first tries iso9660 then udf as filetype.

part of /var/log/messages: hal-subfs-mount[10294]: Collected mount options and Called(0) /bin/mount -t subfs -o fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=iso8859-15 /dev/hdc "/media/dvdrecorder"

comment:4 Changed 12 years ago by ijr

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:5 Changed 12 years ago by Schlaegel

Even if the real world case is not always the ideal case, getting the real world to work should be considered. I don't think every possible case should be accommodated, but at least weigh the cost versus benefit.

Since some distros default to mounting DVDs in a way that makes DVD detection broken, why not just check for both the ucase and lcase version to allow these real world distros to work out of the box.

comment:6 Changed 12 years ago by devel@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

I've also had this problem and written a (rejected) patch for the case insensitivity. I'm using Ubuntu 6.06 which also uses the new hal/submount methods which mount dvd's as iso9660. The only way to get them as udf is to change the fstab entry to force udf which of course breaks every other optical disk... I think this is going to become a major problem as more distros start using this method, but unfortunately the Myth developers do not appear to be open to discussion on the matter. This is their reasoning: "> Could you explain for me why dvd's must be mounted as udf and why it is

a problem if not?

DVD specification... I would say (although it's never really been explicitly said) Myth doesn't want to encourage users to configure their systems improperly because the consequences of the improper configuration would then be partially Myth's fault."

When I have asked what problems are caused by mounting a dvd as iso9660 I have received no response. If I was given a suitable reason for this I would understand the problem... Anyway, if you want to build your own fixed version my patch is ticket #1892.

comment:7 Changed 12 years ago by ijr

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:8 Changed 12 years ago by anonymous

Just a note to the people that were experiencing this problem on Ubuntu 6.06: Changing the fstype from "udf,iso9660" to "auto" in /etc/fstab solved this for me, now both UDF and ISO9660 discs get automounted and detected correctly in MythTV.

This also solved a related problem I had with UDF-only discs not being recognised correctly by mount without specifying the fstype explicitly, which the case insensitivity hack wouldn't have any effect on. I agree with the developers - if the discs aren't correctly recognized by the automounter the automounter is broken, and the responsible parties should be notified so it can be fixed. Other programs will also be affected and fixing it once upstream is preferable to having x programs creating unnecessary workarounds.

Add Comment

Modify Ticket

Action
as closed The owner will remain ijr.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.