Opened 14 years ago

Closed 14 years ago

#1510 closed defect (fixed)

Segmentation fault running mythtranscode (SVN 9343)

Reported by: nick.rosier@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

# mythbackend --version Library API version: 0.19.20060226-1 Source code version: 9343 Options compiled in:

linux release using_v4l using_oss using_alsa using_arts using_jack using_ivtv using_dbox2 using_lirc using_dvb using_dvb_eit using_x11 using_xv using_xrandr using_opengl_vsync using_frontend using_backend

Some recordings fail to transcode; in the backendlog I find this information:

2006-03-14 11:35:55.926 Transcoding from /data/mythtv/recordings//1001_20060312210200.mpg to /data/mythtv/recordings//1001_20060312210200.mpg.tmp
2006-03-14 11:35:55.983 Connecting to backend server: 192.168.1.4:6543 (try 1 of 5)
2006-03-14 11:35:55.993 Using protocol version 27
2006-03-14 11:35:56.000 MainServer::HandleAnnounce Monitor
2006-03-14 11:35:56.000 adding: bulma as a client (events: 0)
[mpeg @ 0xb7585378]Parser not found for Codec Id: 94210 !
0: start_time: 0.036 duration: 232.351
1: start_time: 3394.947 duration: 232.402
2: start_time: 0.025 duration: 232.317
stream: start_time: 0.276 duration: 40303.600 bitrate=338 kb/s
2006-03-14 11:35:56.145 AFD: Opened codec 0x8121030, id(MPEG2VIDEO) type(Video)
2006-03-14 11:35:56.213 AFD: Opened codec 0x8122950, id(MP2) type(Audio)
2006-03-14 11:35:56.354 NVP: Disabling Audio, params(-1,2,44100)
2006-03-14 11:35:56.538 Copying Audio while transcoding Video
2006-03-14 11:35:58.433 Unknown socket closing

The job stays in the jobqueue at 0%; mythtranscode coredumped (SIGSEGV).

Backtrace below:

Thread 3 (process 21935):
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb63af80c in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0xb6ac5200 in QWaitCondition::wait () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#3  0xb77f31e5 in ThreadedFileWriter::DiskLoop () from /usr/lib/libmythtv-0.19.so.0
No symbol table info available.
#4  0xb77f32db in ThreadedFileWriter::boot_writer () from /usr/lib/libmythtv-0.19.so.0
No symbol table info available.
#5  0xb63ac604 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#6  0xb624910e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 2 (process 21937):
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb63af80c in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0xb6ac5200 in QWaitCondition::wait () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#3  0xb77f23d0 in ThreadedFileWriter::SyncLoop () from /usr/lib/libmythtv-0.19.so.0
No symbol table info available.
#4  0xb77f240b in ThreadedFileWriter::boot_syncer () from /usr/lib/libmythtv-0.19.so.0
No symbol table info available.
#5  0xb63ac604 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#6  0xb624910e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (process 21819):
#0  0x00000000 in ?? ()
No symbol table info available.
#1  0x0805efee in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string<char*> ()
No symbol table info available.
#2  0x080579b7 in ?? ()
No symbol table info available.
#3  0xb61a4876 in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#4  0x0804f461 in ?? ()
No symbol table info available.

Change History (3)

comment:1 Changed 14 years ago by nick.rosier@…

Reverted back to my previous build (SVN 9250) and mythtranscode works fine.

comment:2 Changed 14 years ago by anonymous

I've also had this since 9307 (actually a bit earlier). Unfortunately it causes the job queue to get stuck because for some reason the backend doesn't realise that the transcode has crashed (it used to say "ERRORED").

Is the backtrace above without symbols actually useful? I could generate a better one, but perhaps more useful to try to narrow down the revision that causes the problem.

comment:3 Changed 14 years ago by cpinkham

Resolution: fixed
Status: newclosed

This was fixed in [9367]. This bug was also reported in #1514 and I was able to reproduce. The key commonality was audio being disabled: "NVP: Disabling Audio, params(-1,2,44100)".

Note: See TracTickets for help on using tickets.