Opened 13 years ago

Closed 13 years ago

#1511 closed patch (fixed)

DVB livetv tuning and channel changing speedup

Reported by: mark_kendall@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Using svn 9357, starting up livetv and channel changing takes around 7-9 seconds on my system (both dvb-t and dvb-s) and I also get 'jerky' playback (fast/slow/fast/slow) as reported elsewhere on the users list.

Attached patch reduces startup time to around 4 seconds and eliminates the playback problems:-

  • the change to dummydtvrecorder ensures the frontend is seeing the latest writes to the ringbuffer
  • the change to tv_rec provides more sensible (imo) defaults for the dummy recorder and coincidentally fixes the jerky playback (I've also attached a new dummy ts file for these defaults, taken from the uk interactive tv patch)
  • the changes to timeout defaults in the ringbuffer seem to be treating the symptoms rather than the cause ... but it works, ensuring the frontend doesn't sit there for an extra 2 seconds waiting for the ringbuffer.

The comments on NFS optimisation on the wiki are probably pertinent for remote frontends as well.

Mark

Attachments (2)

dvb.diif (2.0 KB) - added by anonymous 13 years ago.
dummy720x576p25.00.ts (13.8 KB) - added by anonymous 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by anonymous

Attachment: dvb.diif added

Changed 13 years ago by anonymous

Attachment: dummy720x576p25.00.ts added

comment:1 Changed 13 years ago by mythtv@…

Applying this patch to SVN 9406 causes LiveTV to fail to start - black screen for about 60 seconds then back to the main menu. Log repeats the following:

2006-03-18 14:26:35.094 RemoteEncoder::SendReceiveStringList(): No response.
2006-03-18 14:26:35.102 WriteStringList: Bad socket
2006-03-18 14:26:35.102 ReadStringList: Bad socket

Followed by:

2006-03-18 14:26:35.142 TV Error: StartRecorder() -- timed out waiting for recorder to start
2006-03-18 14:26:35.142 TV Error: LiveTV not successfully started
2006-03-18 14:26:35.150 TV: Deleting TV Chain in destructor

Reverting my source and recompiling fixes the issue and LiveTV is stable and working once again.

comment:2 Changed 13 years ago by mythtv@…

Forgot to mention I'm using an Happauge NOVA-T (the Philips SAA7146 variety).

comment:3 Changed 13 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk

comment:4 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

Patch was applied in changeset [9534].

Note: See TracTickets for help on using tickets.