Opened 13 years ago

Closed 13 years ago

#1516 closed defect (duplicate)

OSD's are not cleared or too late

Reported by: mrvane@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords: OSD clear
Cc: Ticket locked: no

Description

OSD clearing is broken for me since running SVN 9364, it started the update before, not sure what number. I didn't have any problems with 9116. The strange part is that not all OSD's have the same problem. The item "1: Tuner" when entering liveTV is never cleared. The information OSD (i) (playback time/realtime info) is never cleared, but stops being updated after the configured amount of time (3 s) The channelinfo OSD (o) however, is cleared but only after 30 seconds instead of the configured 3 seconds. Display: via + via XvMC

Attachments (1)

osd_fadeout.diff (672 bytes) - added by stuart@… 13 years ago.
Patch to fix #1516

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by mrvanes@…

mail address should be mrvanes at gmail.com.

comment:2 Changed 13 years ago by cpinkham

Resolution: duplicate
Status: newclosed

Sounds like a dup of #1461.

comment:3 Changed 13 years ago by stuart@…

Resolution: duplicate
Status: closedreopened

This isn't a duplicate of #1461, at least I don't believe it to be the same issue. I've attached a patch which fixes this.

The root cause of this issue was that a value of zero in the <fadeaway> of osd.xml resulted in draw never actually running to remove the OSD.

If someone experiencing the partial fade problem in #1461 could test to see if this also fixes that issue.

Changed 13 years ago by stuart@…

Attachment: osd_fadeout.diff added

Patch to fix #1516

comment:4 Changed 13 years ago by mythdev@…

This fix did not change anything for me on the "watermarking osd" problem. I am using via_xvmc_vld on modular xorg with the OpenChrome? SVN driver. My <fadeaway> is set to 30 in osd.xml. I am using the MythTVMediaCenterOSD theme. I'll try to change the theme. Changing the <fadeaway> to 1 made the OSD stay completely. When I adjust the sound, the "Volume" OSD pops-up which fades away completely. When I skip, the OSD stays as a watermark.

comment:5 Changed 13 years ago by danielk

Milestone: unknown0.20
Owner: changed from Isaac Richards to danielk
Status: reopenednew

I can reproduce this with XvMC surface composite OSD, I'll look at fixing it there, which will hopefully fix it for the other cases.

comment:6 Changed 13 years ago by danielk

This appears to be a duplicate of #1461.

comment:7 Changed 13 years ago by danielk

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.