Opened 14 years ago

Closed 14 years ago

#1532 closed defect (fixed)

cpu_accel.c does not compile on MacOS X

Reported by: mcdermj@… Owned by: Nigel
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

cpu_accel.c doesn't compile cleanly in revision 9400. There's a define that was changed that apparently the Xcode tools version of the assembler isn't happy with.

System Info: MacOS v 10.4.5 Darwin monarchy.xenotropic.com 8.5.0 Darwin Kernel Version 8.5.0: Sun Jan 22 10:38:46 PST 2006; root:xnu-792.6.61.obj~1/RELEASE_PPC Power Macintosh powerpc

Compiler Version: powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5250)

Assembler Version: Apple Computer, Inc. version cctools-590.23.2.obj~17, GNU assembler version 1.38

Patch attached.

Attachments (1)

cpu_accel.c.diff (418 bytes) - added by mcdermj@… 14 years ago.
Patch for cpu_accel.c

Download all attachments as: .zip

Change History (3)

Changed 14 years ago by mcdermj@…

Attachment: cpu_accel.c.diff added

Patch for cpu_accel.c

comment:1 Changed 14 years ago by Nigel

Status: newassigned

Have reproduced the fault on 10.4.3 - looks like r9376 broke the earlier fix (r6777).
I am not 100% happy with using CONFIG_DARWIN as the symbol, because that fault is due to the compiler, not the OS. I will add a check for APPLE, which is for Apple's modifications to GCC, which I think is the cauuse of the different vector assembler syntax.

comment:2 Changed 14 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [9404]) Closes #1532

Note: See TracTickets for help on using tickets.