Opened 14 years ago

Closed 14 years ago

#1550 closed defect (invalid)

mythbackend crashes on some DVB recordings

Reported by: joern.ungermann@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi, I am using vanilla 0.19. This may be related to #793, but the log looks differently, and it does not crash every time for me. I have a PVR-350 + DVB TT-1500 budget setup. There are a couple of issues, but the most critical one is that mythbackend crashes quite reliably after a specific recurring recording at 5:50 in the morning. It does not crash after any other DVB recording and never did after a PVR 350 recording. I can restart the backend afterwards and DVB and PVR work just fine.

I assume that it crashed because the process is not running anymore and no entry in the log indicates a shutdown. After each DVB recording I run a user job that remultiplexes the mpeg2 stream, so I can output it using the PVR hardware decoder. I do not know if this is somehow related.

I reproduced the error quite reliably, but always at the same recording on the same channel.

I attached a logfile of the backend.

I am currently trying to get a backtrace. I'll attach it as soon as it is ready.

Attachments (1)

mythbackend_crash.log.bz2 (49.1 KB) - added by joern.ungermann@… 14 years ago.
Log file of mythbackend (important,general,record,schedule,file,eit), without Sql

Download all attachments as: .zip

Change History (3)

Changed 14 years ago by joern.ungermann@…

Attachment: mythbackend_crash.log.bz2 added

Log file of mythbackend (important,general,record,schedule,file,eit), without Sql

comment:1 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk

comment:2 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

reopen when you get the backtrace...

Note: See TracTickets for help on using tickets.