Opened 14 years ago

Closed 14 years ago

#1551 closed defect (invalid)

mythtranscode segfault

Reported by: otto at kolsi dot net Owned by: cpinkham
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With SVN 9408 mythtranscode segfaults when transcoding recording from MPEG2 -> MPEG2. This happens only for some recordins which are all from DVB-T.

I've attached mythtranscode logs with following commandline options: /usr/local/bin/mythtranscode -j 6 -V 4294901759 -p autodetect -l -v important

There is also backtrace attached (hopefully with all the necessary info?).

Attachments (2)

mythtranscode_segfault_log.txt (2.4 KB) - added by otto at kolsi dot net 14 years ago.
mythtranscode log
mythtranscode_segfault_gdb.txt (9.6 KB) - added by otto at kolsi dot net 14 years ago.
mythtranscode backtrace

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by otto at kolsi dot net

mythtranscode log

Changed 14 years ago by otto at kolsi dot net

mythtranscode backtrace

comment:1 Changed 14 years ago by Geoffrey Hausheer <ghaushe>

It doesn't look like mpeg2->mpeg2 kicked in. can you try adding the --mpeg2 switch and see if the problem is still there? If so I'd want to see that log fie/backtrace. The current isue appears t be with the mpeg2->mpeg4 transcoder which is always called first (unless --mpeg2 is supplied), to determine the stream type.

comment:2 Changed 14 years ago by otto at kolsi dot net

I guess I had that mpeg2->mpeg2 wrong. I currently record from DVB, manually cut commercials and then transcode (just to cut commercials). In schedule, I use Transcode using Autodetect. In recording profiles I have Autodetect from MPEG2 to use RTjpeg codec.

So mythtranscode is doing mpeg2->RTjpeg ? Or is it mpeg2->mpeg4 as you suggested?

Anyway, the problem still stays.. I get from time to time segfault from mythtranscode (see previously attached logs). I can try to produce more logs if needed.

comment:3 Changed 14 years ago by cpinkham

Can you still reproduce this with current SVN head after making sure you do a "make distclean" to make sure everything gets rebuilt properly? If so, I'd like to get ahold of a sample of one of these files, just the first few megabytes. Email me off-list if necessary.

comment:4 Changed 14 years ago by otto at kolsi dot net

Resolution: invalid
Status: newclosed

Unfortunately I don't have those recordings anymore. I think we can close this and I'll re-open it or open a new one if/when I can reproduce the problem with new recordings.

Note: See TracTickets for help on using tickets.