Opened 14 years ago

Closed 14 years ago

#1562 closed defect (invalid)

Remote LiveTV: Ignoring livetv eof in decoder loop

Reported by: brad.zawacki@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using SVN Revision: 9448

LiveTV on backend machine works fine.
Remote frontend LiveTV fails to load and produces a black screen only.

Mythfrontend log has lots of this: 2006-03-21 16:37:02.945 NVP: Waiting for prebuffer.. 0 AAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
2006-03-21 16:37:02.996 Ignoring livetv eof in decoder loop
2006-03-21 16:37:03.052 Ignoring livetv eof in decoder loop
...
2006-03-21 16:37:04.344 NVP: Prebuffer wait timed out 10 times
...

There seems to be some similarities in the log to this ticket:
http://svn.mythtv.org/trac/ticket/1340[[BR]] ...but svn up'ing hasn't fixed it.

'mythfrontend -v playback' log from frontend attached.

Attachments (1)

mythfrontend.log (13.0 KB) - added by brad.zawacki@… 14 years ago.
frontend livetv log

Download all attachments as: .zip

Change History (2)

Changed 14 years ago by brad.zawacki@…

Attachment: mythfrontend.log added

frontend livetv log

comment:1 Changed 14 years ago by brad.zawacki@…

Resolution: invalid
Status: newclosed

I think I've sorted this out.

I had my recordings directory (local on my backend machine) shared via samba, and mounted on my frontend using the same name (/mnt/store) as I use for my recording prefix on the backend.

Apparently that messes with the remote frontend's ability to view livetv. It also causes playback of recordings-in-progress to stop at the endpoint of the show from the time it was opened for playback, rather than continuing on until the recording ends.

Unmounting the share from my frontend solved both problems.

I don't know enough to say if that's a bug or a feature, so I'm invalidating this bug.

Note: See TracTickets for help on using tickets.