Opened 13 years ago

Closed 13 years ago

#1575 closed defect (duplicate)

OSD and XvMC causes stuttering, halted playback

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: stevenrwalter@… Ticket locked: no

Description

When watching an HDTV program with XvMC enabled, whenever the OSD is displayed, the playback becomes jerky (sound and video). When the OSD disappears, the playback resumes are normal, sometimes. Other times, playback stops completely until I hit ESC and return to the program, which fixes playback for a few minutes.

I've found that forcing ChromaKey? OSD fixes the problem. I've followed the guide in the HOWTO for enabling ChromaKey?, however an error message occurs at runtime (output will be attached). The error message was being produced by code designed to keep the ChromaKey? OSD from running on Nvidia 6/7 series cards, however, mine is an FX5500. Changing the if statement to if (0) at videoout_xv.cpp:1257 allows ChromaKey? to be used, and playback to proceed normally.

I'm running mythtv-0.19 on an amd64, X.org server 7.0, and an NVidia FX5500 graphics card.

Attachments (2)

broken.txt (5.8 KB) - added by anonymous 13 years ago.
mythfrontend output with stock 0.19
working.txt (4.1 KB) - added by anonymous 13 years ago.
Output from mythfrontend with ChromaKeyOSD "hacked" on

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by anonymous

Attachment: broken.txt added

mythfrontend output with stock 0.19

Changed 13 years ago by anonymous

Attachment: working.txt added

Output from mythfrontend with ChromaKeyOSD "hacked" on

comment:1 Changed 13 years ago by anonymous

It should be noted that I /always/ get the VideoOutputXv? error message, and video seems to work fine regardless.

comment:2 Changed 13 years ago by anonymous

Cc: stevenrwalter@… added

comment:3 Changed 13 years ago by danielk

Milestone: 0.20
Resolution: duplicate
Status: newclosed
Version: head

Duplicate of #906

Note: See TracTickets for help on using tickets.