Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1591 closed defect (worksforme)

Bad seek tables again

Reported by: tuxvdr@… Owned by: cpinkham
Priority: minor Milestone: 0.20
Component: mythtv Version: 0.19
Severity: medium Keywords: recordedmarkup
Cc: Ticket locked: no

Description

DVB (Mpeg2) recordings made with 0.19 have had bad/corrupt seek tables. The offset information in recordedmarkup is a couple of bytes (2000-10000) behind the real keyframe byte position. As result other functionalities will be affected. Cutting for example doesn't match the desired positions. If I transcode the recording looseless without cutlist, the seektable is rebuild perfectly. If I run mythcommflag --rebuild the seektable is rebuild perfectly but with type 6 (MARK_GOP_START) instead of type 9 (MARK_GOP_BYFRAME).

Found a previours description of this issue in Ticked #816.

Change History (4)

comment:1 Changed 13 years ago by cpinkham

Owner: changed from Isaac Richards to cpinkham

comment:2 Changed 13 years ago by anonymous

Milestone: unknown0.19.1

comment:3 Changed 13 years ago by cpinkham

Resolution: worksforme
Status: newclosed

I think this issue has been fixed in svn head or else we would have heard a lot more about it. If the problem is occurring in head please provide more detailed information such as a partial sample file and the seektable information from the recordedmarkup table to go with the dump. If using svn head as of around mid-July 2006, the seektable is now contained in the 'recordedseek' MySQL table.

comment:4 Changed 13 years ago by (none)

Milestone: 0.19.1

Milestone 0.19.1 deleted

Note: See TracTickets for help on using tickets.