Opened 14 years ago

Closed 14 years ago

#1618 closed defect (fixed)

Inconsistent highlighting on "You are exiting this recording" dialog

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I recently upgraded from 9519 to 9576 and I noticed the selection on the above mentioned dialog will sometimes not highlight. As I cycle through the four options ("Save position" / "Don't save position" / "Keep watching" / "Delete recording"), the current selection will get a change in background color, but the text will no longer change to bright white to highlight the selection.

This is sporadic. Sometimes all four options will highlight as I cycle through, sometimes one or two will highlight and the others stay dark. I tried this in SVN 9609 and it's still a problem.

Attachments (1)

osdtypes.patch (1.2 KB) - added by anonymous 14 years ago.
Fix for non-highlighted osd options

Download all attachments as: .zip

Change History (5)

comment:1 Changed 14 years ago by cpinkham

Resolution: worksforme
Status: newclosed

Move your mouse so somewhere other than the center of the screen.

comment:2 Changed 14 years ago by anonymous

Resolution: worksforme
Status: closedreopened

Thanks for the quick reply, but I really think something is a little out of whack. This happens on two different systems: A frontend only system with no mouse or keyboard, and a frontend/backend system.

I tried your suggestion on my fe/be system but it didn't help. I moved the mouse to the corner of the mythfrontend window and got the same results. Sometimes none of the selections will highlight, othertimes one or more will highlight properly but the rest won't. There is no specific pattern which will highlight, but once the OSD has popped up the same selections consistently work.

This worked fine in 9519. I'll see if I can narrow it down to a more specific version between 9519 and 9576. Is there anything else I should be looking for or providing?

Changed 14 years ago by anonymous

Attachment: osdtypes.patch added

Fix for non-highlighted osd options

comment:3 Changed 14 years ago by cizek@…

This was caused by some missing fields in the copy constructor for OSDTypeText. Specifically, m_selected was uninitialized and was non-zero in random cases.

This dialog inverts the m_font and m_altfont fields. m_font is the highlighted (selected) font and m_altfont is the dim (non-selected) font. OSDTypeText::DrawString?() selects m_altfont if m_selected is non-zero, which was causing mythtv to use the dim font in the wrong cases.

HTH, Bill

comment:4 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: reopenedclosed

(In [9699]) OSDTypeText's copy constructor wasn't complete, and could cause funky highlighting. Patch from #1618 fixes it.

Closes #1618.

Note: See TracTickets for help on using tickets.