Opened 14 years ago

Closed 13 years ago

#1626 closed patch (fixed)

Allow setting of playback group for recording rules and recorded programs

Reported by: derek@… Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The attached patch allows the setting of the playback group for recording rules. I find it easier to just set the playback group when I create a recording rule instead of trying to write regex rules in the frontend to match my program titles.

When I get a chance, hopefully later in the week, I'll also write a patch that allows the editing of the playback group for specific recordings from the 'Recorded Programs' page.

Attachments (6)

set_rule_playgroup.patch (13.7 KB) - added by derek@… 14 years ago.
Allow setting of playback group for recording rules
playgroup.patch (17.3 KB) - added by derek@… 14 years ago.
patch to allow playback group changes from MythWeb
playback_groups.patch (29.5 KB) - added by derek@… 14 years ago.
patch to allow playback group modifications via MythWeb
playback_newfiles.tar.gz (1.4 KB) - added by derek@… 14 years ago.
tarball of new files created under settings module for playback editor
playback_groups.final.patch (33.9 KB) - added by derek@… 14 years ago.
final copy of patch; includes new files and diffs in single patch file
playgroup.2.patch (33.9 KB) - added by derek@… 14 years ago.
updated patch; fixes 'delete recording' regression

Download all attachments as: .zip

Change History (11)

Changed 14 years ago by derek@…

Attachment: set_rule_playgroup.patch added

Allow setting of playback group for recording rules

comment:1 Changed 14 years ago by derek@…

Summary: Allow setting of playback group for recording rulesAllow setting of playback group for recording rules and recorded programs

This latest patch adds to the first one by also allowing changes to the playback group for individual recordings on the 'Recorded Programs' page. This patch replaces the first one.

Part of the patch fixes a bug in includes/programs.php. The program info received from the backend gives the playback group of a recording in field offset 39, but MythWeb incorrectly parses that field as the timestretch field. It appears that the timestretch field is not printed by the backend in ToStringList?(), I therefore just set the value to an empty string.

Changed 14 years ago by derek@…

Attachment: playgroup.patch added

patch to allow playback group changes from MythWeb

comment:2 Changed 14 years ago by derek@…

This final addition to the patch allows creating/editing/deleting of playback groups via MythWeb. This patch replaces the first two.

I could not find a way to force 'svn diff' to include new files in the diff so I'm also adding a tarball of the two new files created. You should apply the patch file (playback_groups.patch) then untar the tarball under mythweb/ (tarball creates two new files under the settings module).

Changed 14 years ago by derek@…

Attachment: playback_groups.patch added

patch to allow playback group modifications via MythWeb

Changed 14 years ago by derek@…

Attachment: playback_newfiles.tar.gz added

tarball of new files created under settings module for playback editor

comment:3 Changed 14 years ago by derek@…

Thanks to some help from Michael Dean, I'm able to get the new files included with the diff, so the latest attachement is a patch that does all the work discussed and does it all in one single patch file. This patch replaces all previous attachments.

Changed 14 years ago by derek@…

Attachment: playback_groups.final.patch added

final copy of patch; includes new files and diffs in single patch file

Changed 14 years ago by derek@…

Attachment: playgroup.2.patch added

updated patch; fixes 'delete recording' regression

comment:4 Changed 14 years ago by derek@…

Updated patch... original patch created a regression by disabling the ability to delete recordings. This latest patch fixes that regression.

comment:5 Changed 13 years ago by xris

Resolution: fixed
Status: newclosed

(In [12986]) Add basic playback group editing. This will eventually be expanded to allow editing of playback groups for recorded programs, too, but I need to make room for it on the recorded details page (closes #1626 and #2862). Also contains some minor tweaks to how saves are handled on the program/recording details page, since I found some issues with how search-type schedules are handled.

Note: See TracTickets for help on using tickets.