Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1633 closed defect (invalid)

Scheduler not resolving conflict

Reported by: derek@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This appears to be a reoccurence of:

http://cvs.mythtv.org/trac/changeset/7391

I'm running 9441. I do have the 'Allow reschedule of higher priorities' turned on. Given the schedule below, I'd expect the baseball game to be recorded and 'Deal or No Deal' to be recorded at 23:00 instead of 20:00. Instead, the ball game is marked as conflicting. If I add an override to force the ball game to record then 'Deal or No Deal' moves to 23:00 and everything gets recorded. As it turns out, someone was playing with the priorities and when I switched them back this situation does not occur (God knows I don't find George Lopez all that funny), but when I move the priorities back to the settings shown below then this scheduler bug is reproduced.

MLB Baseball - "Minnesota at Toront  432 1432  05 19:00-22:00  0 0  A C   0/0
Deal or No Deal                       11 2011  05 20:00-21:00  2 2  A 2   5/0
Deal or No Deal                       17 2017  05 20:00-21:00  0 0  A E   5/0
George Lopez - "George Discovers Ho   18 2018  05 20:00-20:30  0 0  A E   3/0
Rick Mercer Report                   130 1130  05 20:00-20:30  0 0  A E   0/0
Deal or No Deal                      141 1141  05 20:00-21:00  0 0  A E   5/0
George Lopez - "George Discovers Ho  142 1142  05 20:00-20:30  1 3  A 1   3/0
George Lopez - "George Discovers Ho  175 1175  05 20:00-20:30  0 0  A E   3/0
Deal or No Deal                      176 1176  05 20:00-21:00  0 0  A E   5/0
Heist - "Strife"                      17 2017  05 21:00-22:00  2 2  A 2   5/0
Heist - "Strife"                     114 1114  05 21:00-22:00  0 0  A E   5/0
Rick Mercer Report                   131 1131  05 21:00-21:30  0 0  A E   0/0
Heist - "Strife"                     176 1176  05 21:00-22:00  0 0  A E   5/0
Heist - "Strife"                       3 2003  05 22:00-23:00  0 0  A E   5/0
Law & Order - "Positive"              17 2017  05 22:00-23:00  2 2  A 2   7/0
Heist - "Strife"                     117 1117  05 22:00-23:00  0 0  A E   5/0
Rick Mercer Report                   132 1132  05 22:00-22:30  0 0  A E   0/0
Law & Order - "Positive"             176 1176  05 22:00-23:00  0 0  A E   7/0
The Daily Show With Jon Stewart       44 2044  05 23:00-23:30  2 2  d 2   7/0
Deal or No Deal                      123 1123  05 23:00-00:00  0 0  A E   5/0
The Daily Show With Jon Stewart      105 1105  05 23:05-23:35  0 0  d E   7/0
The Colbert Report                    44 2044  05 23:30-00:00  2 2  d 2   7/0
The Colbert Report                   105 1105  05 23:35-00:07  0 0  d E   7/0

Attachments (3)

sched.out (52.5 KB) - added by derek@… 14 years ago.
Output of '--testsched'
sched1.2.patch (944 bytes) - added by gigem 14 years ago.
sched.out2 (71.7 KB) - added by derek@… 14 years ago.
Output of '--testsched' with debug code patched in

Download all attachments as: .zip

Change History (10)

comment:1 Changed 14 years ago by gigem

Resolution: worksforme
Status: newclosed

Please restart your backend with -v schedule or run "mythbackend -v schedule --testsched" instead and provide the output.

comment:2 Changed 14 years ago by derek@…

Resolution: worksforme
Status: closedreopened

As requested, here is the output of 'mythbackend -v schedule --testsched'.

Changed 14 years ago by derek@…

Attachment: sched.out added

Output of '--testsched'

comment:3 Changed 14 years ago by gigem

That does look odd. Please apply sched1.patch to get some more information and run --testsched again.

Changed 14 years ago by gigem

Attachment: sched1.2.patch added

comment:4 Changed 14 years ago by derek@…

Updated output attached.

Changed 14 years ago by derek@…

Attachment: sched.out2 added

Output of '--testsched' with debug code patched in

comment:5 Changed 14 years ago by derek@…

Just a quick FYI: I'm going to lose this reproducable situation at 7pm EDT when my evening's recordings start and I've checked the rest of my schedule and I don't see this situation occurring anywhere else. If you see this in time and if there's anything you'd like me to save/do to help debug this then please let me know.

comment:6 Changed 14 years ago by gigem

Resolution: invalid
Status: reopenedclosed

I trust you adjusted your priorities to get everything to record. That is the recommended solution for now.

The problem is that you ran into the limitation that the scheduler only tries one level of undo/redo to move programs around. This was caused because the baseball game was only available at one time on one tuner and had a low priority.

Specifically, by the time the scheduler considered the baseball game, the only tuner it could be recorded on was reserved for "George Lopez". Since that episode of "George Lopez" was also only available at one time and your other tuner was already reserved for other programs, it couldn't be moved and the baseball game couldn't be scheduled.

I'm closing this report as invalid since the behavior is as designed. Until someone adds more levels of undo/redo or writes a new scheduler this will happen occasionally. Since the scheduler does an acceptable job in most cases, and those cases where it doesn't can usually be resolved by adjusting priorities and/or adding overrides, such changes are an extremely low priority for me.

comment:7 Changed 14 years ago by gigem

(In [9629]) Added a more visibility into the SchedMoveHigher? logic when -v schedule is used. Refs #1633.

Note: See TracTickets for help on using tickets.