Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#1651 closed defect (fixed)

mythtranscode segfaults during mpeg2 => mpeg2 transcode

Reported by: Lueddich Owned by: Geoffrey Hausheer
Priority: minor Milestone: 0.20
Component: mythtv Version: 0.19
Severity: medium Keywords: mythtranscode lossless mpeg2 segfault
Cc: xris Ticket locked: no

Description

Transcoding recordings with losless option segfaults mythtranscode. The output file grows and grows and short under the size of the original file, mythtranscode segfaults. The original filesize is 2641MB, the new one 2405MB, but theres nothing being cutted off. I also have 4 new files in the directoryafter the error occuring:

-rwx------ 1 mythtv mythtv 0 Apr 5 16:19 ins0.enc -rwx------ 1 mythtv mythtv 0 Apr 5 16:19 ins0.enc.yuv -rwx------ 1 mythtv mythtv 0 Apr 5 16:19 ins0.enc.yuv.enc -rwx------ 1 mythtv mythtv 0 Apr 5 16:19 ins0.yuv

I attached several logfiles including a backtrace, but I don't know wether the backtracing really worked. I did my best! ;)

If you would like to see what I did including the install of build 9647 you could have a look at http://mysettopbox.tv/phpBB2/viewtopic.php?t=9489&postdays=0&postorder=asc&start=0

Attachments (7)

mythbackend_log.txt (2.6 KB) - added by Lueddich 14 years ago.
mythtranscode_commandline.txt (362 bytes) - added by Lueddich 14 years ago.
mythtranscode_commandline_verbose_all.txt (14.8 KB) - added by Lueddich 14 years ago.
mythtranscode_commandline_strace.txt (7.8 KB) - added by Lueddich 14 years ago.
mythtranscode_commandline_gdb.txt (931 bytes) - added by Lueddich 14 years ago.
NUV2DISC-log.txt (2.3 KB) - added by Lueddich 14 years ago.
mythtranscode_commandline_gdb_debug_build.txt (4.1 KB) - added by Lueddich 14 years ago.

Download all attachments as: .zip

Change History (25)

Changed 14 years ago by Lueddich

Attachment: mythbackend_log.txt added

Changed 14 years ago by Lueddich

Changed 14 years ago by Lueddich

Changed 14 years ago by Lueddich

Changed 14 years ago by Lueddich

comment:1 Changed 14 years ago by anonymous

Even Nuv2Disc has a error trying to cut commercials, I add the logfile. I am using KnoppMyth? R5B7 including MythTV 0.19, updated from KnoppMyth? R4A30.2 including MythTV 0.18 and updated to SVN build 9647. Could it be a database-problem, that mythtranscode and nuv2disc can't use the cut points?

Changed 14 years ago by Lueddich

Attachment: NUV2DISC-log.txt added

comment:2 Changed 14 years ago by mac

I also was having this problem. Installing the latest ffmpeg from cvs appears to have cleared up issue.

comment:3 Changed 14 years ago by Lueddich

In my case, reinstalling ffmpeg didn't work... :( The error is still the same...

comment:4 Changed 14 years ago by mac

I am still having it as well.

I transcoded a file without a cutlist and finished fine. Transcoding with cutlist causes to segfault on what appears to be the second pass.

comment:5 Changed 14 years ago by Geoffrey Hausheer <ghaushe>

Owner: changed from Isaac Richards to anonymous
Status: newassigned

You need to rerun the gdb trace after enabling a debug build. Note that mythtranscode has nothing to do with ffmpeg directly. mythtranscode only uses libraries included within myth, so it uses libmythavcodec, libmythavformat, and libmythmpeg2. Installing other packages will have no impact on the results.

comment:6 Changed 14 years ago by Geoffrey Hausheer <ghaushe>

Owner: changed from anonymous to Geoffrey Hausheer
Status: assignednew

comment:7 Changed 14 years ago by Lueddich

I'll do my very best ;)

At the moment, I try to find out, how to rebuild mythtv including the svn-update within KnoppMyth?... When I have results these days, I'll post them ASAP.

Thanks!

Changed 14 years ago by Lueddich

comment:8 Changed 14 years ago by anonymous

I did it, a guy helped me with rebuilding...

Attached the mythtranscode_commandline_gdb_debug_build.txt

Is there still something missing? Can I do anything?

comment:9 Changed 14 years ago by xris

fyi, I see this with a handful of my firewire-encoded shows, too.. The file will often grow only a small amount (usually to the first cut, I think) and then mythtranscode segfaults. I tried to get a backtrace but it contained no useful info, and I got too busy to figure out what else I could do. Just thought I'd chime in with a "please fix." :) And of course, let me know if I can do anything to help.

comment:10 Changed 14 years ago by xris

Cc: xris added

comment:11 Changed 14 years ago by Lueddich

Priority: minormajor

I updated to build 9787 yesterday, but the error is still there... Can I do anything?

comment:12 Changed 14 years ago by Isaac Richards

Priority: majorminor

comment:13 Changed 14 years ago by Lueddich

Keywords: lossless mpeg2 added

Hey Geoffrey,

are you still on this? I'm still having these problems... :( During the last day, I did a clean install of KnoppMyth? R5C7 and updated MythTV to the svn from June 01. Same Error...

Can I do anything? Could I send you a short recording to have a look at it? ... ?

Please help me! ;) MythTV is such a great thing, but without this MPEG2-cutting it's not possible to produce nice DVDs from recordings... :( That's a pity!!

Thank you!

comment:14 Changed 13 years ago by anonymous

Milestone: 0.19.1

comment:15 Changed 13 years ago by Lueddich

Hi,

is there anybody watching this ticket or even working on it? Is there a chance, that this is fixed? If not, it would be nice to inform me... I could stop watching this ticket every 2 days in that case...

Thanks!

comment:16 Changed 13 years ago by Lueddich

Resolution: fixed
Status: newclosed

If anybody at any time reads this... The problem is gone! I updated to SVN 10293 yesterday and I can transcode now using the losless-option...

Great work...

comment:17 in reply to:  16 Changed 13 years ago by anonymous

Replying to Lueddich:

If anybody at any time reads this... The problem is gone! I updated to SVN 10293 yesterday and I can transcode now using the losless-option...

Great work...

Was working for me but now seems broken in a recent SVN of release-0-19-fixes (up through changeset 10505?). Any attempt at a mpeg2->mpeg2 transcode ends with an "Unknown socket closing" error in the backend logs. Running the commands by hand shows that it's segfaulting at or near the end.

comment:18 Changed 13 years ago by (none)

Milestone: 0.19.1

Milestone 0.19.1 deleted

Note: See TracTickets for help on using tickets.