Opened 14 years ago

Closed 14 years ago

#1670 closed defect (invalid)

LiveTV makes mythfrontend freeze

Reported by: jimi@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: 0.19
Severity: medium Keywords:
Cc: Isaac Richards Ticket locked: no

Description

Basicly mythfrontend freezes when trying to watch LiveTV. I start mythfrontend, and go directly to watching live tv, and then get a blank screen where X11 freezes.

Here is what might be critical in myth.log (see attachment):

[mpeg @ 0xb766a360]Parser not found for Codec Id: 94210 !

X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  140
  Minor opcode:  14
  Resource id:  0x1bc
2006-04-10 23:36:38.628 VideoOutputXv Error: Couldn't get the color key color,
                        probably due to a driver bug or limitation.
                        You might not get any video, but we'll try anyway.

Here is the entire gdb-output:

[Thread debugging using libthread_db enabled]
[New Thread -1239759168 (LWP 5506)]
[New Thread -1242539088 (LWP 5514)]
[New Thread -1256834128 (LWP 5517)]
[New Thread -1265226832 (LWP 5518)]
[Thread -1265226832 (LWP 5518) exited]
[New Thread -1265226832 (LWP 5533)]
[New Thread -1388524624 (LWP 5539)]
[New Thread -1396917328 (LWP 5540)]
[New Thread -1411105872 (LWP 5541)]
[New Thread -1433404496 (LWP 5542)]

Attachments (1)

myth.log (4.0 KB) - added by jimi@… 14 years ago.
myth.log

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by jimi@…

Attachment: myth.log added

myth.log

comment:1 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

The VideoOutputXv? error would not result in a freeze, at worst it would mean the video screen would be blank, but you would still hear the audio and the UI would be responsive.

Also, if X11 freezes it is a X11 bug or a driver/os bug.

comment:2 Changed 14 years ago by jimi@…

Resolution: invalid
Status: closedreopened

When I use mplayer directly in X11, I don't have any problems with watching TV.

When using mythfrontend it results in a freeze, blank screen, no sound and the IU is unresponsive. mythfrontend is the only program where X11 freezes.

Anyone have an idea what might be causing this ?

comment:3 Changed 14 years ago by kkuphal

Resolution: invalid
Status: reopenedclosed

Trac is not a discussion forum. Please take this to the -users list and if asked, the -dev list for debugging.

Note: See TracTickets for help on using tickets.