Opened 14 years ago

Closed 13 years ago

#1715 closed defect (worksforme)

Flicker, high cpu & sampling loop when viewing program directory after watching show - live preview off, thumbnail on

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Quick Description:

I'm using the latest svn of the 019-fixes (fyi). After my kids watched one of their shows, they left myth at the 'All Programs' directory. Later in the day my log area filled up. After looking into it, I noticed the mythfrontend log was filled with:

. . 2006-04-16 15:32:58.290 AFD: Opened codec 0x8e17cf0, id(MPEG2VIDEO) type(Video) 2006-04-16 15:32:58.290 AFD: Opened codec 0x8fa4c70, id(MP2) type(Audio) 0: start_time: 0.036 duration: 161.655 1: start_time: 0.030 duration: 161.663 stream: start_time: 0.334 duration: 1796.256 bitrate=4180 kb/s . . . This goes on and on for hours every second. Once I exited the directory, these messages stopped.

System Information Mandriva LE2006 fully patched Kernel: 2.6.12-18mdk #1 Wed Mar 15 13:15:23 MST 2006 i686 AMD Sempron(tm) Processor 3100+ unknown GNU/Linux /proc/driver/nvidia/cards/0 Model: GeForce4 MX 4000 IRQ: 10 Video BIOS: 04.18.20.46.00 Card Type: AGP

Detailed log and myth settings: See attached

Attachments (2)

previewlog.log (9.6 KB) - added by anonymous 14 years ago.
previewlog.2.log (9.6 KB) - added by mythtv@… 14 years ago.

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by anonymous

Attachment: previewlog.log added

Changed 14 years ago by mythtv@…

Attachment: previewlog.2.log added

comment:1 Changed 13 years ago by skamithi

Resolution: invalid
Status: newclosed

invalid ticket. user should have asked this question on the user forum instead of opening a ticket.

comment:2 Changed 13 years ago by rbonafied@…

Resolution: invalid
Status: closedreopened

Hi,

I'm not sure why the ticket is invalid, but for what it's worth, I did open it in the user forums. Here is the link: http://www.gossamer-threads.com/lists/mythtv/users/199284?search_string=rbonafied%40yahoo.com;#199284

Being a newbie, I would like to understand what I did wrong that caused the ticket to be invalid.

Thank you!

comment:3 Changed 13 years ago by cpinkham

In the thread you linked to, you mention that you were able to reproduce the issue "after some experimentation." Can you please provide a better description of what steps you were going through when the problem occurred. Also, please attach the frontend logs from "mythfrontend -v all" starting with the first time you see "Preview: previewThreadDone" and ending with the next time you see that same phrase so we can see one cycle of what is going on.

comment:4 Changed 13 years ago by danielk

Resolution: worksforme
Status: reopenedclosed

Reporter does not give steps to reproduce, did not respond to info query three weeks ago, and I can not reproduce the problem with SVN head.

The problem appears to be due to regenerating the preview repeatedly, so this is probably due to permissions problems with the recording directory which we perform some acrobatics to work around in SVN head.

Note: See TracTickets for help on using tickets.