Opened 13 years ago

Closed 13 years ago

#1736 closed patch (fixed)

automatic enabling of subtitles broken (patch included)

Reported by: Pekka Jääskeläinen <pekka.jaaskelainen@…> Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords: subtitles
Cc: Ticket locked: no

Description

If subtitles need to be enabled by default (DefaultCCMode setting), they weren't enabled in case the stream didn't have subtitles when InitVideo?() was called. Subtitles need to be re-enabled as soon as subtitles are encountered.

Fix: Always on subtitle stream change re-enable (and reselect) the subtitles.

Attachments (1)

fix_enable_subtitles_by_default.diff (10.5 KB) - added by Pekka Jääskeläinen <pekka.jaaskelainen@…> 13 years ago.

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by Pekka Jääskeläinen <pekka.jaaskelainen@…>

comment:1 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [9805]) Closes #1736. Refs #1682. Fixes autoselection of subtitle/caption streams when the streams are not immediately available.

Caption streams are often not detected until a few seconds into playback. This means the autoselect was usually selecting Teletext 888 or CC-1 captions rather than the more desirable options, such as a caption stream in one of your preferred languages.

This references #1682 only because I accidentally placed a version of the patch there.

Note: See TracTickets for help on using tickets.