Opened 13 years ago

Closed 13 years ago

#1761 closed enhancement (duplicate)

Allow detection of DVDs with (illegal) lowercase "video_ts" dir

Reported by: lists@… Owned by: Isaac Richards
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords: dvd autodetect
Cc: Ticket locked: no

Description

I have a few DVDs probably made on a windows machine where the /video_ts directory is in lowercase (instead of the correct "/VIDEO_TS" case)

This makes the auto detect code see it as a disc full of photos and open mythgallery.

The attached patch is in the style of the existing VCD/SVCD detect and checks for the two obvious types of upper/lowercase. Arguably there could be all kinds of in between options, but this at least seems to catch the most likely scenario

Attachments (1)

detect_lc_dvd.diff (958 bytes) - added by lists@… 13 years ago.
Detect DVD using lowercase dir names

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by lists@…

Attachment: detect_lc_dvd.diff added

Detect DVD using lowercase dir names

comment:1 Changed 13 years ago by Anduin Withers

Resolution: duplicate
Status: newclosed

Duplicate of #1499 (which wasn't a bug)

Note: See TracTickets for help on using tickets.