Opened 13 years ago

Closed 13 years ago

#1769 closed patch (fixed)

Tuning error with no SDT present

Reported by: Mark.Buechler@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Janne Grunau requested that I open a ticket for this which he helped me debug. The problem is with tuning a DVB channel which has no SDT (or NIT for that matter). Happens on PBSHD on AMC3 in the US. This is against the mythtv-eit branch.

Attachments (1)

patch.diff (889 bytes) - added by Mark.Buechler@… 13 years ago.
The patch..

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by Mark.Buechler@…

Attachment: patch.diff added

The patch..

comment:1 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk

comment:2 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

If it doesn't have a SDT it is not a DVB channel.

Are you sure it is not an ATSC channel?

Even if it is not it should be caught by the "Check if this is an MPEG channel" code a little later in tv_rec.cpp (int mythtv-eit).

comment:3 Changed 13 years ago by Janne <janne-mythtv@…>

Resolution: invalid
Status: closedreopened

Daniel, the currentOriginalNetworkID is initialized with -1. After the automic cast to uint it is something greater 0. So it tries to tune to the channel as DVB channel and gets never a lock since the SDT is missing.

comment:4 Changed 13 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [9925]) Fixes #1769 in mythtv-eit. If the netid is -1, with this change we fall back to MPEG tuning rather than try DVB tuning with the invalid netid.

Note: See TracTickets for help on using tickets.