Opened 13 years ago

Closed 10 years ago

#1770 closed defect (invalid)

EIT w/DataDirect can cause unwanted scheduling changes

Reported by: fracmak Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - EIT Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Recently updated to the latest release of the cvs and I've been noticing some weird glitches that happen when one recording ends and one begins. I'll record a show at 8pm on fox, that show will end at 9pm, but another show begins at 9pm, and myth records it, but labels it as the show at 8pm, and then proceeds to record the show at 9pm at 10pm with the correct label(which turns out to be a completely different show). And just tonight, I recorded two shows, one after another, but this time on seperate channels. The same behavior occurred, except this time Myth didn't change channels, so it ended up recording the completely wrong show.

Attachments (2)

ConsecutiveRecordingsLog.txt (4.1 KB) - added by fracmak 13 years ago.
mythbackend2_verbose.log (82.4 KB) - added by fracmak 13 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 13 years ago by gigem

Resolution: invalid
Status: newclosed

I don't have clue what you're trying to say. Please try again. Logs or other specifics would probably be helpful too.

Changed 13 years ago by fracmak

comment:2 Changed 13 years ago by fracmak

Resolution: invalid
Status: closedreopened

I'm having a problem with recording consecutive shows. I've attached part of my backend log from last night. My intention was to record House on Fox at 8pm, and Lost on ABC at 9pm. I often like to start a recording a minute early, and end it a minute late, but because of how close the shows were, I had to make an override for each show that night. What ended up happening as you can see from the Backend log, House recorded just fine at 8pm, but at 9pm, instead of switching to record Lost on ABC, it started recording House again on Fox (which was actually American Idol) and it never recorded Lost. This wasn't a problem with the program guide because I specifically set up override settings to make sure each program would record correctly.

comment:3 Changed 13 years ago by gigem

I suspect the problem is bad guide data being added from EIT scanning. You'll need to run your backend with "-v schedule" to confirm and see how and why the scheduler changes the upcoming schedule.

Changed 13 years ago by fracmak

Attachment: mythbackend2_verbose.log added

comment:4 Changed 13 years ago by fracmak

Ok, I ran the backend with -v schedule and have uploaded a new log: "mythbackend2_verbose.log". This time I scheduled back to back shows of "That '70s Show" on Fox at 8pm and 8:30pm, followed by an episode of "My Name is Earl" on NBC at 9pm. Instead of having the glitch I explained above, it recorded the first "That '70s Show", missed the 2nd showing, and recorded "My Name is Earl" just fine.

comment:5 Changed 13 years ago by gigem

Owner: changed from Isaac Richards to danielk
Status: reopenednew

As I kind of expected, the EIT scanning is overwriting your DataDirect? guide data. If you look on the "Previously Recorded", you should see programs marked as NotListed?. This means the programs was scheduled at one point but was later removed from the guide data.

I'm reassigning this bug to Daniel in case he wants to add anything. I think the problem can be fixed with a configuration change or will be fixed by Daniel's pending EIT changes.

comment:6 Changed 13 years ago by danielk

Priority: majorminor
Summary: Weird scheduling glitchEIT w/DataDirect can cause unwanted scheduling changes

This should be fixed by one of the planned EIT fixes.

At the current rate the fix should be committed to mythtv-eit in three weeks, and make it to svn head in six weeks.

Until then, the one data source per channel workaround described in the mailing list will work.

comment:7 Changed 13 years ago by danielk

Milestone: 0.200.21

comment:8 Changed 13 years ago by fracmak

This is a duplicate of #2143 and can be closed.

comment:9 Changed 13 years ago by danielk

This is not a duplicate of #2143.

comment:10 Changed 13 years ago by danielk

(In [11619]) Refs #1770. Splits filldata.cpp functions into functional classes.

This looks like a big change, but in fact none of the code had been changed except to move functions and variables to classes (or main).

The Data Direct program insertion function was moved to DataDirectProcessor?, the other program data insertion and deletion functions were moved to ProgramData?. The xmltv parsing functions were moved to the XMLTVParser class, the channel data update/delete/insert functions were moved to ChannelData?, the icon data update/insert functions were moved to IconData?, and the overall logic was moved to FillData?, while main() was moved to main.cpp and still does the command line parsing and manipulates the classes.

To make the EIT data insertion compatible with XMLTV/DataDirect data I need the program data insertion classes to be accessible to the EIT processor in libmythtv. So the main reason for the splitting is to move the program data insertion methods to libmythtv. At some point in the future it might be useful to have access to the other portions of fill data for the frontend channel editor, but for now I've left the code in mythfilldatabase.

I've tested this with DataDirect? and two XMLTV data grabbers. Although since very little code has changed it is more likely that there might be header problems.

comment:11 Changed 12 years ago by danielk

Component: mythtveit

comment:12 Changed 12 years ago by danielk

Milestone: 0.21unknown

comment:13 Changed 11 years ago by Dibblah

Status: newassigned

comment:14 Changed 10 years ago by stuartm

Component: eitMythTV - EIT

comment:15 Changed 10 years ago by robertm

Resolution: invalid
Status: assignedclosed

Closing as something we've never explicitly supported, though it might be nice to allow EIT to amend XML-provided listings, it's just a bag of hurt making it work. Patches cheerfully accepted :)

Note: See TracTickets for help on using tickets.