Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#1798 closed defect (fixed)

Video playback broken - audio only. in r9915

Reported by: adrian.wilkins@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords: video black screen
Cc: Ticket locked: no

Description

Playback in LiveTV or from archive plays back the audio but the video is only a black screen.

This occurs using libmpeg2, Standard XvMC, and Standard playback, with or without deinterlace filters. OpenGL vsync on or off.

Video decode still works, as preview stills and video still work properly.

Hardware is a Sempron with onboard nForce2/Geforce 2MX graphics, running nvidia kernel module and GLX drivers 1.0.7667

The change that breaks this occurs in r9915 of /trunk (confirmed, 9914 works fine, 9915 exhibits the fault).

Attachments (1)

configure.txt (934 bytes) - added by adrian.wilkins@… 14 years ago.
Output of ./configure

Download all attachments as: .zip

Change History (8)

comment:1 Changed 14 years ago by danielk

Milestone: 0.20

what are your ./configure options?

Also, please attach the output of ./configure

Also, what version of X.org are you using?

comment:2 Changed 14 years ago by danielk

(In [9926]) Refs #1798. Make it hard to accidentally enable XvMC w/OpenGL rendering.

Now you need to explicitly enable it in svn-head, even if you explicitly link against the nvidia XvMC library.

Changed 14 years ago by adrian.wilkins@…

Attachment: configure.txt added

Output of ./configure

comment:3 Changed 14 years ago by adrian.wilkins@…

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.17-rc1-mm2 i686 [ELF]
Current Operating System: Linux aeris 2.6.14-mm2 #3 PREEMPT Mon Apr 24 09:29:41 BST 2006 i686

As you can see (and I hadn't exactly realised), I have built Xorg against a newer kernel version than I am running ; I don't know enough to know if this is a problem ; but everything seems to work just fine at the present (and running with 9914). I shall probably rebuild it at some point.

I use the older .7667 driver as whenever I have tried to change up (in the hopes of getting stable XvMC playback), I get horrible problems like 100% CPU consumption and choppy playback (is this part of the "OpenGL VSync problem"?). A spate of attempts to change the driver version were provoked by recent builds of Myth that had problematic playback on my hardware (but not stupid CPU consumption). Happily these have been resolved now. Changing the driver version upwards requires you to upgrade your kernel. I haven't had a proper try with the .8756 driver yet as I've had some trouble getting a configuration that will compile.

Since my standard playback CPU usage rarely goes above 25%, my desire for XvMC playback to work was originally motivated by playback quality ; full-screen panning was noticably smoother using XvMC. But XvMC has always been noticably more flaky ; the chances of it crashing the frontend during a given playback has always been virtually 100% (aggravated by doing heinous things like skipping and pausing). With more recent code syncs to the playback libraries, quality has improved noticably and I'm less inclined to desire XvMC. Reliability is paramount as the audience for the unit is mostly non-tech.

Since I've seen vast quality improvements in non-accelerated playback (ffmpeg) by keeping pace with HEAD, it makes me sad to think that I might have to stop at r9914.... I reckon I have pretty common HTPC hardware too, there must be a lot of people with onboard GF4MX out there....

I'm happy to work to resolve this, but my spare time for doing so is very limited indeed......

---

Configure script below.

#! /bin/bash
./configure \
\
--cpu=athlon-xp \
--arch=athlon-xp \
--disable-ccache \
--enable-proc-opt \
--disable-altivec \
--disable-audio-oss \
--disable-audio-arts \
--disable-audio-jack \
--disable-joystick-menu \
--disable-firewire \
--disable-dbox2 \
--disable-hdhomerun \
--disable-ivtv \
--disable-v4l \
--enable-dvb \
--disable-xrandr \
--enable-xvmc \
--disable-xvmc-vld \
--enable-opengl-vsync \

comment:4 Changed 14 years ago by danielk

Severity: highmedium

Adrian, do you still have problems with the current svn?

It looks this is the problem that I fixed in the [9926] commit. (you need to rerun ./configure and recompile)

./configure thought that you wanted to use the nVidia OpenGL output method because you linked directly to libXvMCNVIDIA.so instead of the XvMC wrapper library. But since you are using X.org 6.8.2 the wrapper library is still an external library which you haven't installed. Using the nVidia OpenGL output method in SVN head requires that you use XvMC for output, but since you were using XVideo output the OpenGL texture was just blank.

comment:5 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

Pretty sure this was closed by [9926].

Adrian, reopen the ticket if you are still experiencing problems.

comment:6 Changed 13 years ago by adrian.wilkins@…

I'll give this a go later : incidentally, what is the library required for XvMC OpenGL support under nVidia that I am missing?

comment:7 Changed 13 years ago by adrian.wilkins@…

Confirm that this does work in my default configuration, installed r9988 this morning.

I might try the XvMC later.

Note: See TracTickets for help on using tickets.