Opened 14 years ago

Closed 13 years ago

#1813 closed defect (fixed)

Msg: 'Error was encountered while displaying

Reported by: clemens@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Isaac Richards)

This problem occurs with 0.19 SVN for versions over the last two weeks or so. It definately occurs in 0.19.2006.0331-1 compiled from SVN on 11may2006

Watching TV localy, things run till about 6sec after the hour, and then get the above message. This SEEMS to be related to the following line in the mythfrontend log file.

2006-05-10 00:00:06.727 RingBuf?(/mnt/video/Recordings/1051_20060510000000.mpg): Invalid file (fd -1) \

when opening '/mnt/video/Recordings/1051_20060510000000.mpg'.

The directory is writable, and there is plenty of space, so why the open should fail will take a look at the code itself.

This error is in the current SVN code (as of 11May2006) and has been there for at least a week.

Here are the two files I posted with a message to MythTV-Users on 10may2006

--- Here it is with no options on mythfrontend, note the (fd -1) msg...

2006-05-09 11:30:37.287 Opening OSS audio device '/dev/dsp'.
2006-05-09 11:30:37.290 NVP: Enabling Audio
2006-05-09 11:30:41.563 NVP: prebuffering pause
2006-05-09 12:00:08.053 NVP: prebuffering pause
2006-05-09 12:26:56.512 NVP: prebuffering pause
2006-05-09 12:30:01.879 NVP: prebuffering pause
2006-05-09 12:31:31.279 NVP: prebuffering pause
2006-05-09 13:56:56.388 NVP: prebuffering pause
2006-05-09 13:58:21.656 NVP: prebuffering pause
2006-05-09 13:58:23.055 NVP: Prebuffer wait timed out 10 times.
2006-05-09 13:58:23.540 NVP: prebuffering pause
2006-05-09 13:58:23.752 NVP: prebuffering pause
2006-05-09 13:58:23.969 NVP: prebuffering pause
2006-05-09 13:58:24.172 NVP: prebuffering pause
2006-05-09 13:58:24.373 NVP: prebuffering pause
2006-05-09 13:58:24.580 NVP: prebuffering pause
2006-05-09 13:58:24.786 NVP: prebuffering pause
2006-05-09 13:58:24.989 NVP: prebuffering pause
2006-05-09 13:58:25.193 NVP: prebuffering pause
2006-05-09 14:00:01.966 NVP: prebuffering pause
2006-05-09 14:00:03.369 NVP: Prebuffer wait timed out 10 times.
2006-05-09 14:00:04.769 NVP: Prebuffer wait timed out 10 times.
2006-05-09 14:00:06.169 NVP: Prebuffer wait timed out 10 times.
2006-05-09 14:00:06.965 RingBuf(/mnt/video/Recordings/1051_20060509140000.mpg): Invalid file (fd -1) when opening '/mnt/video/Recordings/1051_20060509140000.mpg'.
2006-05-09 14:00:06.965 NVP, Error: SwitchToProgram's OpenFile failed.
2006-05-09 14:00:06.965 NVP, Error: Unknown error, exiting decoder
2006-05-09 14:00:06.965 TV: Attempting to change from WatchingLiveTV to None
2006-05-09 16:00:24.012 Received a remote 'Clear Cache' request
2006-05-09 18:55:11.044 TV: Changing from WatchingLiveTV to None

===================================

And here we go again, but this time with mythfrontend --verbose playback

'video_output' mean = '33359.45', std. dev. = '1403.98', fps = '29.98'
2006-05-09 23:59:57.896 AFD: positionMap[ 107768 ] == -1456785388.
2006-05-09 23:59:58.396 AFD: positionMap[ 107783 ] == -1456148820.
2006-05-09 23:59:58.896 AFD: positionMap[ 107798 ] == -1454851056.
2006-05-09 23:59:59.397 AFD: positionMap[ 107813 ] == -1453730012.
2006-05-09 23:59:59.898 AFD: positionMap[ 107828 ] == -1452903000.
2006-05-10 00:00:00.400 AFD: positionMap[ 107843 ] == -1451962248.
2006-05-10 00:00:00.538 LiveTVChain(live-mythtv.dwf.com-2006-05-09T19:00:04): ReloadAll(): Added new recording
2006-05-10 00:00:00.538 Resyncing position map. posmapStarted = 0 livetv(1) watchingRec(0)
2006-05-10 00:00:00.705 NVP: 539200 interlaced frames seen.
'video_output' mean = '33492.42', std. dev. = '2444.33', fps = '29.86'
2006-05-10 00:00:00.932 Position map filled from DB to: 107847
2006-05-10 00:00:00.934 SyncPositionMap watchingrecording, from DB: 7381 entries
2006-05-10 00:00:00.936 SyncPositionMap watchingrecording no entries from encoder, try DB
2006-05-10 00:00:01.013 AFD: positionMap[ 107858 ] == -1450912268.
2006-05-10 00:00:01.147 LiveTVChain(live-mythtv.dwf.com-2006-05-09T19:00:04): SwitchTo(5)
2006-05-10 00:00:01.147 LiveTVChain(live-mythtv.dwf.com-2006-05-09T19:00:04): Entry@5: '1051_20060510000000'
2006-05-10 00:00:01.151 NVP: IsReallyNearEnd() br(500KB) fps(29) sz(0KB) vfl(25) frh(0) ne:1
2006-05-10 00:00:01.151 SwitchToProgram(void)
2006-05-10 00:00:01.227 RingBuf(/mnt/video/Recordings/1051_20060509230000.mpg): OpenFile(myth://204.134.2.12:6543/1051_20060510000000.mpg, 10)
2006-05-10 00:00:01.366 SyncPositionMap watchingrecording total: 7382 entries
2006-05-10 00:00:01.366 SyncPositionMap, new totframes: 107858, new length: 3598, posMap size: 7382
2006-05-10 00:00:01.932 NVP: prebuffering pause
2006-05-10 00:00:01.933 NVP: Waiting for prebuffer.. 0 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:01.950 LiveTVChain(live-mythtv.dwf.com-2006-05-09T19:00:04): ReloadAll(): Added new recording
2006-05-10 00:00:02.075 NVP: Waiting for prebuffer.. 1 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:02.215 NVP: Waiting for prebuffer.. 2 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:02.355 NVP: Waiting for prebuffer.. 3 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:02.495 NVP: Waiting for prebuffer.. 4 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:02.635 NVP: Waiting for prebuffer.. 5 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:02.775 NVP: Waiting for prebuffer.. 6 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:02.915 NVP: Waiting for prebuffer.. 7 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:03.055 NVP: Waiting for prebuffer.. 8 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:03.195 NVP: Waiting for prebuffer.. 9 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:03.335 NVP: Prebuffer wait timed out 10 times.
2006-05-10 00:00:03.335 NVP: Waiting for prebuffer.. 0 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:03.475 NVP: Waiting for prebuffer.. 1 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:03.615 NVP: Waiting for prebuffer.. 2 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:03.755 NVP: Waiting for prebuffer.. 3 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:03.895 NVP: Waiting for prebuffer.. 4 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:04.035 NVP: Waiting for prebuffer.. 5 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:04.175 NVP: Waiting for prebuffer.. 6 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:04.315 NVP: Waiting for prebuffer.. 7 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:04.455 NVP: Waiting for prebuffer.. 8 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:04.595 NVP: Waiting for prebuffer.. 9 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:04.735 NVP: Prebuffer wait timed out 10 times.
2006-05-10 00:00:04.735 NVP: Waiting for prebuffer.. 0 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:04.875 NVP: Waiting for prebuffer.. 1 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:05.015 NVP: Waiting for prebuffer.. 2 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:05.155 NVP: Waiting for prebuffer.. 3 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:05.295 NVP: Waiting for prebuffer.. 4 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:05.435 NVP: Waiting for prebuffer.. 5 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:05.575 NVP: Waiting for prebuffer.. 6 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:05.715 NVP: Waiting for prebuffer.. 7 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:05.855 NVP: Waiting for prebuffer.. 8 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:05.995 NVP: Waiting for prebuffer.. 9 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:06.135 NVP: Prebuffer wait timed out 10 times.
2006-05-10 00:00:06.135 NVP: Waiting for prebuffer.. 0 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:06.275 NVP: Waiting for prebuffer.. 1 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:06.415 NVP: Waiting for prebuffer.. 2 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:06.555 NVP: Waiting for prebuffer.. 3 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:06.695 NVP: Waiting for prebuffer.. 4 AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:06.727 RingBuf(/mnt/video/Recordings/1051_20060510000000.mpg): Invalid file (fd -1) when opening '/mnt/video/Recordings/1051_20060510000000.mpg'.
2006-05-10 00:00:06.727 RingBuf(/mnt/video/Recordings/1051_20060510000000.mpg): CalcReadAheadThresh(4000 KB)
                         -> threshhold(146 KB) min read(32 KB) blk size(64 KB)
2006-05-10 00:00:06.727 NVP, Error: SwitchToProgram's OpenFile failed.
2006-05-10 00:00:06.728 NVP, Error: Unknown error, exiting decoder
2006-05-10 00:00:06.728 NVP: Exited decoder loop.
2006-05-10 00:00:06.728 TV: Attempting to change from WatchingLiveTV to None
2006-05-10 00:00:06.728 TV: StopStuff() -- begin
2006-05-10 00:00:06.728 TV: StopStuff(): stopping ring buffer[s]
2006-05-10 00:00:06.728 TV: StopStuff(): stopping player[s] (1/2)
2006-05-10 00:00:06.728 TV: StopStuff(): stopping recorder[s]
2006-05-10 00:00:06.857 VideoOutputXv: dtor
2006-05-10 00:00:06.857 VideoBuffers::DiscardFrames(1): AAAAAAAAAAaAALAuAAAAAAAAAAAAAAA
2006-05-10 00:00:06.857 VideoBuffers::DiscardFrames(): AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA -- done()
2006-05-10 00:00:06.857 VideoBuffers::DiscardFrames(1): AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA -- done
2006-05-10 00:00:06.869 VideoOutputXv: Closing XVideo port 61
2006-05-10 00:00:06.919 TV: StopStuff(): stopping player[s] (2/2)
2006-05-10 00:35:58.314 TV: StopStuff() -- end
2006-05-10 00:35:58.314 TV: Changing from WatchingLiveTV to None

Attachments (1)

mythlogs.tbz2 (68.8 KB) - added by dscoular@… 14 years ago.
mythfrontend and mythbackend logs with requested verbose flags.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 14 years ago by Isaac Richards

Description: modified (diff)
Priority: majorminor
Resolution: invalid
Status: newclosed

Need backend logs with -v record at a minimum. Please attach files instead of pasting into the ticket description, too.

Changed 14 years ago by dscoular@…

Attachment: mythlogs.tbz2 added

mythfrontend and mythbackend logs with requested verbose flags.

comment:2 Changed 14 years ago by dscoular@…

Resolution: invalid
Status: closedreopened

Hi Isaac, I'm seeing the infamous "Error was encountered while displaying video" when SwitchToProgram? is called. I've attached a bzip2'd tar file containing both the mythfrontend and mythbackend logs with verbose flags "playback" and "record,channel,general,important" respectively.

This is on a 0.19-fixes svn DVB-T setup with a Hauppauge Nova-T (tda1004x) card:

spug mythtv # svn info Path: . URL: http://svn.mythtv.org/svn/branches/release-0-19-fixes/mythtv Repository Root: http://svn.mythtv.org/svn Repository UUID: 7dbf422c-18fa-0310-86e9-fd20926502f2 Revision: 10180 Node Kind: directory Schedule: normal Last Changed Author: danielk Last Changed Rev: 10143 Last Changed Date: 2006-06-08 06:41:03 +1000 (Thu, 08 Jun 2006) Properties Last Updated: 2006-05-20 23:57:14 +1000 (Sat, 20 May 2006)

It's linked against ffmpeg-0.4.9_p20060530.ebuild which is the most recent for gentoo.

Hope this helps... please don't hesitate to contact me should you need any more info.

Cheers,

Doug

comment:3 Changed 13 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk
Status: reopenednew
Summary: Msg: 'Error was encountered while displaying Msg: 'Error was encountered while displaying video'Msg: 'Error was encountered while displaying

comment:4 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

Please test against 0.20, it appears the problem is with streaming the a short dummy file which we no longer generate. I'm going to assume this is fixed until I hear otherwise, since we don't generate the problem file.

comment:5 Changed 13 years ago by anonymous

Resolution: fixed
Status: closedreopened
Version: 0.190.20

Hello, I'm Dimitris and i'm having the same problem with version 0.20 It's not as often as it used to be with the previous version (svn Revision: 10698). I'm using a skystar2 budget card and i get this error when i tune to a few encrypted channels

RingBuf?(/mnt/store/1509_20060913020844.mpg): Invalid file (fd -1) when opening '/mnt/store/1509_20060913020844.mpg

comment:6 Changed 13 years ago by Isaac Richards

Resolution: fixed
Status: reopenedclosed
Version: 0.200.19

Not the same problem.

Note: See TracTickets for help on using tickets.