Opened 13 years ago

Closed 11 years ago

#1840 closed patch (fixed)

Interactive TV - small rendering fix.

Reported by: mark_kendall@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

There are numerous small errors in the display of MHEG interactive streams. Hard to describe as overall the display looks OK but boxes and lines are not displayed accurately.

This is caused by rounding of the position of each rectangle displayed (to simplify blending into the osd surface). Calling SetDontRoundPosition? causes all sorts of problems in the blending process.

The solution here is to add an extra transparent row and/or column to the displayed image which ensures rounding doesn't affect positioning and everything is displayed as expected.

(p.s. There looks to be a similar problem with rendering bitmaps that I haven't tracked down yet.)

Attachments (3)

interactive.diff (2.7 KB) - added by anonymous 13 years ago.
mheg-osx.jpg (186.8 KB) - added by Sam Jacobs <samuel@…> 11 years ago.
MHEG rendering errors (OS X)
mheg-linux.jpg (171.8 KB) - added by Sam Jacobs <samuel@…> 11 years ago.
MHEG rendering errors (Linux)

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by anonymous

Attachment: interactive.diff added

comment:1 Changed 13 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk

comment:2 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [10001]) Fixes #1840. Fixes an off-by-one error in placement of ITV objects caused by rounding.

comment:3 Changed 11 years ago by Sam Jacobs <samuel@…>

Resolution: fixed
Status: closednew

Hi,

This appears to have cropped up again. I'm attaching two screenshots, one from Linux and another from Mac OS X. The linux build is 0.21-fixes rev. 16838 from Mythbuntu, and the Mac build is 0.21-fixes rev. 17113.

I hope that re-opening an old bug is the correct thing to do. This is only the second time I've done anything like this, so if I've got it wrong please tell me why!

Thanks, Sam

Changed 11 years ago by Sam Jacobs <samuel@…>

Attachment: mheg-osx.jpg added

MHEG rendering errors (OS X)

Changed 11 years ago by Sam Jacobs <samuel@…>

Attachment: mheg-linux.jpg added

MHEG rendering errors (Linux)

comment:4 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

Sam, please open a new ticket, and if possible please include a a picture of a screen rendered correctly and incorrectly.

Note: See TracTickets for help on using tickets.