Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1841 closed defect (fixed)

Mythtv ignores audio tracks

Reported by: cizek@… Owned by: cpinkham
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After I upgraded from svn 9759 to 9953, mythtranscode can't find the audio tracks in certain recordings, and as a result drops all of the audio.

I've attached logs from the following:

mythtranscode -v audio -p autodetect  -i 1321_20060515194800.mpg -o /hdtv2/tmp/out.mpg

If there's anything else I can provide, let me know.

Attachments (2)

9759.log (2.4 KB) - added by anonymous 13 years ago.
Good transcode
9953.log (2.0 KB) - added by anonymous 13 years ago.
transcode missing audio

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by anonymous

Attachment: 9759.log added

Good transcode

Changed 13 years ago by anonymous

Attachment: 9953.log added

transcode missing audio

comment:1 Changed 13 years ago by anonymous

Summary: Mythtranscode drops audio tracksMythtv ignores audio tracks

This started in svn 9820. It happens when transcoding or watching the recordings in mythfrontend.

I looked through the changes in 9820 and 9825 but I'm clueless as to how to work around this. Anyone have any ideas?

comment:2 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

I need a sample recording to debug this. Please reopen when one is available for download.

comment:3 Changed 13 years ago by gary@…

Resolution: invalid
Status: closedreopened

I've had the same problem. As posted by Bill Cizek on -dev, the following change fixes the problem:

Index: libs/libavformat/utils.c
===================================================================
--- libs/libavformat/utils.c	(revision 10084)
+++ libs/libavformat/utils.c	(working copy)
@@ -1995,7 +1995,7 @@
 #define MAX_READ_SIZE        5000000
 
 /** Number of frames to read, max. */
-#define MAX_FRAMES           15
+#define MAX_FRAMES           200
 
 /** Maximum duration until we stop analysing the stream. */
 #define MAX_STREAM_DURATION  ((int)(AV_TIME_BASE * 2.0))

comment:4 Changed 13 years ago by gary@…

btw, if you want a sample that this happens with, send me an email and I'll put a "small" (10 minute) mpg on my web server (it's slow for upstream, but.... )

For some reason, with me, the problem only occurs if mythtranscode -m is run via the FE.. twice. I can run it over and over and over via CLI, and I have no problem.

comment:5 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

Patch would significantly slow down channel changes. As the previous comment said, I need a sample to properly debug things.

comment:6 Changed 13 years ago by Isaac Richards

Resolution: invalidfixed

(In [10112]) Loosen search restrictions when looking for streams.

Should fix #1841.

Note: See TracTickets for help on using tickets.