Opened 14 years ago

Closed 14 years ago

#1846 closed defect (worksforme)

Aspect override is broken to recorded programs when using seperate video modes for GUI/TV playback

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords: asoect ratio mythfrontend custom
Cc: Ticket locked: no

Description

In SVN when using aspect ratio overrides set in the Video Mode Settings->Seperate video modes for GUI and TV playback the settings take effect for live tv but not recorded programs, settings are ignored. Same happenes when watching programs in MythVideo? using the Internal player.

Works fine in 19-fixes branch

Attachments (1)

1846.patch (797 bytes) - added by danielk 14 years ago.
possible fix

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk

Changed 14 years ago by danielk

Attachment: 1846.patch added

possible fix

comment:2 Changed 14 years ago by danielk

Does the attached patch make any difference?

comment:3 Changed 14 years ago by wiggi

hi, ive noticed this, applying and testing now

comment:4 Changed 14 years ago by wig

patch appears to have made no difference. Am using 12 hours old svn with the patch applied. Still live tv always switches to correct custom ratio but recorded programs are always shown in 4:3

My setup is a Nvidia card with XV out, resolution set to 800x600 in X but Myth set to 788x584 in screen settings due to overscan. Use GUI size for TV playback is selected, and on the next setup page Seerate video modes for GUI and TV playback is selected with GUI and Video Output set to 800x600 with any rate and an aspect of 16:9. This always used to force all programs on live tv and the internal player to be forced into 16:9 aspect ratio but now only works for live tv.

If you need any further info like db dumps please let me know

comment:5 Changed 14 years ago by danielk

Resolution: worksforme
Status: newclosed

Could not reproduce.

Note: See TracTickets for help on using tickets.