Opened 13 years ago

Closed 13 years ago

#1855 closed defect (invalid)

mythdvd and via xvmc segfaults on prev chapter when in first chapter

Reported by: mythdev@… Owned by: skamithi
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using previous chapter when there isn't one segfaults under via xvmc, doesn't segfault if not xvmc.

Attached patch stops segfault and seems ok - but I don't know the code well enough (don't know it at all actually) to know whether this will create a memory leak/other problems.

The problem is in the line ca 2750 in libavcodec/mpeg12.c

 s->current_picture_ptr->qscale_type= FF_QSCALE_TYPE_MPEG2;

because in the segv circumstances current_picture_ptr is 0x0

Attachments (1)

dvdprevchaptersegv.diff (550 bytes) - added by mythdev@… 13 years ago.
Patch for mythdvd prevchapter segv under xvmc

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by mythdev@…

Attachment: dvdprevchaptersegv.diff added

Patch for mythdvd prevchapter segv under xvmc

comment:1 Changed 13 years ago by Anduin Withers

Owner: changed from Anduin Withers to skamithi

comment:2 Changed 13 years ago by Anduin Withers

Component: mythdvdmythtv

comment:3 Changed 13 years ago by skamithi

Status: newassigned

in the slice_end() function it checks to see if s->current_picture_ptr is null.

if its null by the time it gets to the part mentioned, then another thread may have cleared the structure. need the gdb dump to begin to figure it out.

sent creator of the ticket an email asking for the gdb dump, if the issue is still reproducible.

comment:4 Changed 13 years ago by skamithi

Resolution: invalid
Status: assignedclosed

closing this ticket. can't reproduce. need gdb dump.

Note: See TracTickets for help on using tickets.