Opened 13 years ago

Closed 13 years ago

#1870 closed defect (invalid)

StartPlayer timeout of 20 seconds too short for VIA Epia-M frontend

Reported by: klaas.de.waal@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Start of playback of recordings on a VIA Epia-M frontend sometimes fails with this error: TV Error: StartPlayer?(): NVP is not playing after 20000 msec

The StartPlayer? code is in libs/libmythtv/tv_play.cpp I have changed two things in this file:

  • increase the default timeout value from 20000 to 40000
  • change the wait loop sleep time from 50 microseconds to 50000 microseconds

A sleep time of 50 microseconds is very small and causes CPU time to be wasted in the wait loop. For reference, one video frame is 20 milliseconds (PAL).

With these changes I can now play back any recording, the worst startup time is now: TV: StartPlayer?(): took 25490 ms to start player.

I have attached a patch for tv_play.cpp for the 0.19 stable revision 10024.

Attachments (2)

tv_play.cpp.patch (567 bytes) - added by klaas.de.waal@… 13 years ago.
tv_play.cpp change StartPlayer? timeout from 20 to 40 seconds
tv_play.cpp.2.patch (733 bytes) - added by klaas.de.waal@… 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by klaas.de.waal@…

Attachment: tv_play.cpp.patch added

tv_play.cpp change StartPlayer? timeout from 20 to 40 seconds

comment:1 Changed 13 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [10032]) Close #1870 by applying patch (increases timeout value for starting a recorder).

Would be better to figure out _why_ it's taking so long on the reporter's machine, of course.

Changed 13 years ago by klaas.de.waal@…

Attachment: tv_play.cpp.2.patch added

comment:2 Changed 13 years ago by klaas.de.waal@…

Resolution: fixed
Status: closedreopened

Previous patch was for StartRecorder? which did not solve the problem. New patch tv_play.cpp.2.patch is for StartPlayer? which did solve the problem for me. Sorry for the mistake. About the causes of the delay:

  • backend is a slow P3 800Mhz/256MB
  • with a fast P4 2.6GHz/768MB frontend total delay always less than 20 seconds
  • with the VIA Epia-M 600MHz frontend total delay often exceeds 20 seconds
  • biggest part of the delay comes from MySQL processing at the backend

comment:3 Changed 13 years ago by anonymous

But you're still just increasing the delay rather than fixing/working out what the problem is. 20 seconds is a ridiculous wait for playback to start.

comment:4 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

Not applying due to submittor sending out obviously untested patch previously.

Note: See TracTickets for help on using tickets.