Opened 14 years ago

Closed 14 years ago

#191 closed defect (duplicate)

Some recorded streams cause std::bad_alloc in mythfrontend

Reported by: Mike Cannon <m_cannon@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.18.1
Severity: medium Keywords: bad_alloc, firewire, 6200
Cc: m_cannon@… Ticket locked: no

Description

Problem

Some recorded streams* cause std::bad_alloc in mythfrontend.

System

Fedora Core 4 using mythtv-0.18.1-113.rhfc4.at.i386.rpm Also when built from mythtv-0.18.1-113.rhfc4.at.src.rpm and it has been reported on FC3.

Analysis

What's characteristic about this is the stream has (at the beginning) frames with 0 height/width and you get OSDSet::m_wmult and OSDSet::m_hmult set to 0.0.

Next time in OSDSet::Reinit()...

    float wchange = wmult / m_wmult;       // inf
    float hchange = hmult / m_hmult;       // inf

and soon, eg, OSDTypeEditSlider::Reinit() tries (osdtypes.cpp:1228) to do

    ...  new unsigned char[m_drawwidth + 1]; 
              // m_drawwidth == -2147483648

(*)

Perhaps 20% of recordings from a Motorola STB DCT-62xx via firewire seem to cause this.

Change History (1)

comment:1 Changed 14 years ago by Isaac Richards

Resolution: duplicate
Status: newclosed

Duplicate of #25.

Note: See TracTickets for help on using tickets.