Opened 13 years ago

Closed 13 years ago

#1921 closed defect (fixed)

Mediamonitor get stuck on data dvd insertions

Reported by: philipvanbogaert@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythgallery Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The media monitor is configured to playback dvd menu. Autofs is enabled (using the latest knoppmyth distribution). Latest version of mythtv is compiled and used (version of Jun 4 2006)

When inserting a data dvd, mythgalary is started (which is ok for me) But it is impossible to exit the galary e.g: pressing escape just starts the MythGallary? over and over again.

Thanks, Philip

Attachments (6)

fstab (478 bytes) - added by anonymous 13 years ago.
gallerylog.txt (2.3 KB) - added by anonymous 13 years ago.
xout2.log (2.7 KB) - added by anonymous 13 years ago.
fe-mediatest1.txt (5.8 KB) - added by torbjorn.jansson@… 13 years ago.
commented logfile from first test
fe-mediatest2.txt (4.8 KB) - added by torbjorn.jansson@… 13 years ago.
commented logfile from second test
1921-v1.patch (7.9 KB) - added by danielk 13 years ago.
Possible fix

Download all attachments as: .zip

Change History (22)

comment:1 Changed 13 years ago by anonymous

Same for usb-stick full of mp3's or cd/dvd full of films.

And why does it open mythgallery anyway? There are only some folder.jpg files and tons of other files on the device.

comment:2 Changed 13 years ago by danielk

Resolution: worksforme
Status: newclosed

I just checked the usb-stick of mp3's and a DVD, both worked.

Make sure you have recompiled and installed the music handler.

As for 'cd/dvd full of films', there is no media handler for that so MythGallery is probably the closest match.

comment:3 Changed 13 years ago by anonymous

Resolution: worksforme
Status: closedreopened

I'm having the same problem as the original poster. Please note that the problem is not with MythGallery opening, which is fine, but with not being able to exit MythGallery.

When I start MythGallery from the menu, pressing Esc will get me back to the main menu. When MythGallery starts automatically on inserting a DVD with pictures, pressing Esc only restarts MythGallery and I have to Ctrl-Alt-Backspace out and restart X to get mythfrontend up and running again.

comment:4 Changed 13 years ago by anonymous

make distclean/make/make install (mythtv and mythplugins)

Still impossible to exit mythgallery until the cd/dvd is removed from tray. Only If you eject the CD/DVD, you can exit maythgallery.

comment:5 Changed 13 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk
Status: reopenednew

I still can't reproduce this problem.

Can you attach a "mythfrontend -v file" log; annotate the log with when you tried to edit mythgallery and it failed.

Also, please attach your fstab file.

Anonymous, are you also using Knoppmyth? If not which distro is this?

comment:6 Changed 13 years ago by anonymous

I'm not on my mediacenter right now, but I'll attach the logs as soon as possible.

Til then: I'm using Suse 10.0 and my fstab doesnt contain something interesting, because SuSe? 10.0 is using a combination of hal an submount. If a CD is inserted the mount command is giving something like that:

/dev/hdc on /media/dvdrecorder type subfs (ro,nosuid,nodev,fs=cdfss,procuid,iocharset=iso8859-15)

But I remember i tried in fstab:

/dev/hdc /media/dvdrecorder auto user,noauto,ro,nosuid,exec,iocharset=utf8 0 0

and I had the same problem... I'll check that back.

comment:7 Changed 13 years ago by anonymous

I'm the 2nd anonymous poster from the top, sorry for confusion. I'm on Ubuntu 6.06. I just noticed - when I start mythfrontend with a CD already mounted, it works fine. The problem occurs only when the CD is automounted while mythfrontend is running. What occurs then is this:

  1. Mythgallery opens with a list of the files on the CD
  2. I press Escape
  3. Mythgallery displays a list of two folders, "/dev/scd0" (selected) and "Gallery" (to the left)
  4. Pressing Escape again returns me to the list of files on the CD, as does selecting either "/dev/scd0" or "Gallery" from the list

I'll attach my fstab and the file produced by mythfrontend -v, as well as the output from X's standard output.

Changed 13 years ago by anonymous

Attachment: fstab added

Changed 13 years ago by anonymous

Attachment: gallerylog.txt added

Changed 13 years ago by anonymous

Attachment: xout2.log added

Changed 13 years ago by torbjorn.jansson@…

Attachment: fe-mediatest1.txt added

commented logfile from first test

Changed 13 years ago by torbjorn.jansson@…

Attachment: fe-mediatest2.txt added

commented logfile from second test

comment:8 Changed 13 years ago by torbjorn.jansson@…

i've done 2 tests with my hama usb cardreader and attached the logfiles. the first test was done with both a cf and sd card, frontend opened mythmusic at start.

the second test was with only a cf card with one picture and one text file on it, gallery was started when frontend started.

i've added comments to both of the logfiles

frontend version

# mythfrontend --version
Library API version: 0.19.20060631-1
Source code version: 10124M
Options compiled in:
 linux debug using_xvmcw using_v4l using_oss using_alsa using_arts using_ivtv using_dbox2 using_hdhr using_ip_rec using_lirc using_joystick_menu using_dvb using_x11 using_xv using_xrandr using_xvmc using_xvmc_vld using_frontend using_backend

comment:9 Changed 13 years ago by danielk

Ok, I managed to reproduce this.

If I mount two media devices (flagged for import in mythgallery) before I start mythfrontend it forms some kind of loop in the import portion of mythgallery. Somehow this doesn't happen if I allow MythTV to mount the devices.

I'll have a look at this tomorrow.

comment:10 Changed 13 years ago by torbjorn.jansson@…

i don't know if you noticed it or not, but in the first log file where the frontend mounted the devices none of the 2 mounted cards showed up on the "device folder" screen.

but in the second test where the card was already mounted when the frontend started it displayed the vfat partition.

and another thing i noticed while testing this, the frontend only mounts the devices when it starts, if i plug in an usb stick or remove the usb cable to the card reader nothing happends and nothing is logged from mediamonitor.

Changed 13 years ago by danielk

Attachment: 1921-v1.patch added

Possible fix

comment:11 Changed 13 years ago by danielk

Type: defectpatch

comment:12 in reply to:  11 Changed 13 years ago by anonymous Nr.1

Replying to danielk: Tried the Patch. For me it works better now. Most of the time, I can exit the window and eject the media, but sometimes pressing 'esc' only brings me up one directory and I can browse throug all directories but I cannot exit. This happens only with some CD's. I think they all have m_MediaType: 256.

2006-06-19 13:09:09.481 Executing '/bin/mount /dev/hdc' 2006-06-19 13:09:09.744 Looking for: '/media/dvdrecorder/VIDEO_TS' 2006-06-19 13:09:09.865 Looking for: '/media/dvdrecorder/vcd' 2006-06-19 13:09:09.865 Looking for: '/media/dvdrecorder/svcd' 2006-06-19 13:09:14.256 m_MediaType: 256 2006-06-19 13:09:14.257 Media status changed... New status is: MEDIASTAT_MOUNTED old status was MEDIASTAT_NOTMOUNTED 2006-06-19 13:09:14.257 Posting MediaEvent? 2006-06-19 13:09:14.258 Found a handler 2006-06-19 13:09:14.261 XMLParse::LoadTheme? using /usr/local/share/mythtv/themes/default/gallery-ui.xml

comment:13 Changed 13 years ago by danielk

(In [10236]) Refs #1921. Fixes the original reported problem with exiting from MythGallery.

The problem fixed here has to do with a check in the iconview exit code that assumed your cursor would either be on the Gallery dir or the first removable device when you tried to exit the device view. But if there is more than one removable device, this is not always the case.

I'm not closing the ticket because there appears to be another less common problem exiting from MythGallery due to some other bug.

comment:14 Changed 13 years ago by danielk

Type: patchdefect

comment:15 Changed 13 years ago by danielk

(In [10701]) Fixes #2114. Refs #1921. Allows exiting from subfolders in MythGallery when media monitoring is disabled without unintenionally exiting from plugin.

comment:16 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [10706]) Fixes #1921. Fixes main problems with media monitored devices in MythGallery.

1/ Allows subdirectories on mounted media to be explored. 2/ Prevents Escape for going above the mounted media subdirectory when the mounted media is explored on disk insertion. 3/ Allows exiting from device monitor when a device rather than the gallery is selected. 4/ Exits menu when you select the "Show Devices" menu entry. The user generally wants to explore the devices after showing them, not select another menu button.

Note: See TracTickets for help on using tickets.