Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1989 closed defect (duplicate)

Mythweather reporting wrong days (0.19.20060621-1)

Reported by: tlawton@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythweather Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythweather reports information for wrong days eg today is friday 23rd

'current conditions' is correct 'extended forecast' shows fri/sat/sun 'tomorrow's weather' shows details for thursday (yesterday) - nb states 'forecast for thursday' 'doppler radar' is correct

Checking weather through mythweb: 'Forecast' shows mon/tue/wed/thur/fri(today) only, no information for sat/sun 2006-06-23 22:35:29.228 HttpComms::Timeout for url: http://www.msnbc.com/m/chnk/d/weather_d_src.asp?acid=UKXX0078 2006-06-23 22:35:29.244 HttpComms::done() - NetworkOperation? Error on Finish: Request aborted (1): url: 'http://www.msnbc.com/m/chnk/d/weather_d_src.asp?acid=UKXX0078' 2006-06-23 22:35:39.821 UIImageType::LoadImage?() - Cannot find image: 06/27/2006

Location UKXX0078 (Leeds, United Kingdom)

Errors from mythfrontend log - none

*Reloaded: 'current conditions' is correct 'extended forecast' now shows sat/sun/mon 'tomorrow's forecast' does not exist, replaced by 'today's forecast' 'doppler radar' 2006-06-23 22:35:29.228 HttpComms::Timeout for url: http://www.msnbc.com/m/chnk/d/weather_d_src.asp?acid=UKXX0078 2006-06-23 22:35:29.244 HttpComms::done() - NetworkOperation? Error on Finish: Request aborted (1): url: 'http://www.msnbc.com/m/chnk/d/weather_d_src.asp?acid=UKXX0078' 2006-06-23 22:35:39.821 UIImageType::LoadImage?() - Cannot find image: 06/27/2006 is correct

Errors from mythfrontend log: 2006-06-23 22:35:29.228 HttpComms::Timeout for url: http://www.msnbc.com/m/chnk/d/weather_d_src.asp?acid=UKXX0078 2006-06-23 22:35:29.244 HttpComms::done() - NetworkOperation? Error on Finish: Request aborted (1): url: 'http://www.msnbc.com/m/chnk/d/weather_d_src.asp?acid=UKXX0078' 2006-06-23 22:35:39.821 UIImageType::LoadImage?() - Cannot find image: 06/27/2006

*Reloaded again: 'current conditions' is correct 'extended forecast' now shows tue/wed/thur 'tomorrow's outlook' shows 'forecast for monday' 'doppler radar' is correct

Errors from mythfrontend log: 2006-06-23 22:38:44.098 HttpComms::Timeout for url: http://www.msnbc.com/m/chnk/d/weather_d_src.asp?acid=UKXX0078 2006-06-23 22:38:44.117 HttpComms::done() - NetworkOperation? Error on Finish: Request aborted (1): url: 'http://www.msnbc.com/m/chnk/d/weather_d_src.asp?acid=UKXX0078'

As you can see the selected information appears quite random!

Change History (4)

comment:1 Changed 13 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:2 Changed 13 years ago by anonymous

Resolution: duplicate
Status: closedreopened

Unsure why closed - no duplicate identified on search (searching in component: mythweather, both closed and open). Bug occurs using svn checked out today. I note that the wiki states:

Fixed forecast showing wrong day information

However this bug occurs with 0.19.20060621-1 as stated.

comment:3 Changed 13 years ago by Isaac Richards

Resolution: duplicate
Status: reopenedclosed

comment:4 Changed 13 years ago by anonymous

It would be extremely useful for those trying to figure out what's going on to know which bug this is considered a duplicate of. Since someone was obvious obstinate about closing this as a duplicate, I won't bother re-opening it. But as far as I'm concerned, unless someone else comments to the contrary or posts the relevant dupe, this is an open, undupe'd, and unfixed bug. It still exists in 0.20, and is not really the same bug as http://svn.mythtv.org/trac/ticket/1988 or http://svn.mythtv.org/trac/ticket/1426 . I have seen the same bug in earlier installs with 0.19. In my current case, today is Sunday. The extended forecast shows "Fri Sat Sun" and Tomorrow's forecast shows Friday. There are no significant errors output in the trace. In case it's of any use, the zip is 02472.

Note: See TracTickets for help on using tickets.