Opened 13 years ago

Closed 13 years ago

#2009 closed defect (fixed)

shutdown is not prevented if recording is scheduled via mythweb

Reported by: andersin@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.19
Severity: medium Keywords: shutdown
Cc: Ticket locked: no

Description

Summary

When mythtv is set to shut down automatically after some idle time, once the system thinks it is idle, recordings that are scheduled with mythweb do not prevent the shutdown if they fall in the 'Max. wait for recording' interval. This causes problems when the recording is to start within the next 10 minutes. nvram-wakeup will not write the startup time to /dev/nvram and the system will not wake up.


Steps to reproduce:

  • Set the following options:
    • Idle timeout = 900
    • Max wait for recording = 30
    • Startup before rec = 300
    • Set wakeuptime command = nvram-wakeup -s $(($time + 300))
  • Quit all clients connecting to backend. Backcend log will say

I'm idle now... shutdown will occur in 900 seconds.

  • schedule some recording via mythweb that starts 20 minutes in the future.

The backend will acknowledge that it sees the schedule but will keep counting down Scheduled 1 items in 0.0 = 0.03 match + 0.02 place 370 secs left to system shutdown!

After 15 min (900 sec), the backend will shutdown after nvram-wakeup complains that the time is not 10 minutes in the future.


Additional Note:

While searching the web to see if this issue has been reported before, I came across some posts where using mythweb caused the machine to shut down (http://www.mythtv.org/pipermail/mythtv-users/2006-January/117751.html). I am not sure if mythweb was changed because of this.


Expected Behavior:

The scheduler should detect that the upcoming recording falls within the 'max wait for recording' and prevent the backend from shutting down.

Change History (1)

comment:1 Changed 13 years ago by paulh

Resolution: fixed
Status: newclosed

Fixed by [10652]

Note: See TracTickets for help on using tickets.