Opened 13 years ago

Closed 13 years ago

#2032 closed defect (fixed)

Duplicate Naming Broken when PSIP not present and channels misnamed

Reported by: joshua.prismon@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Stuart Auchterlonie Ticket locked: no

Description

This was recently broken, I can not reproduce using a older build.

When scanning Comcast (QAM64, no PSIP information) -

The scan finds channels, but assigns them all the same name (the name of the first channel it finds). So for example, if it finds a Channel UNKNOWN13#1, it writes that to the database. Next it finds channel 83-3 but it calls that channel UNKNOWN13#1.

Two problems

  • Only one channel is in the channels at the end of the proccess, UNKNOWN13#1.
  • In situations where the PSIP can't be found, can we still name according to user preference? I asked Myth to store each channel with a "." seperator (so I wanted 13.1), instead it bailed and called it "UNKNOWN13#1"

I will attach log shortly.

Attachments (2)

BrokenScan.gz (30.3 KB) - added by anonymous 13 years ago.
mythtv-setup -v all
2032-v1.2.patch (541 bytes) - added by danielk 13 years ago.
Patch to fix channel insert problem

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by anonymous

Attachment: BrokenScan.gz added

mythtv-setup -v all

comment:1 Changed 13 years ago by anonymous

(note, it's actually just channel, siparser and record not -v all). It's still huge.

comment:2 Changed 13 years ago by Stuart Auchterlonie

Cc: Stuart Auchterlonie added
Milestone: 0.20
Owner: changed from Isaac Richards to danielk
Version: head

Changed 13 years ago by danielk

Attachment: 2032-v1.2.patch added

Patch to fix channel insert problem

comment:3 Changed 13 years ago by danielk

Joshua, can you try the attached patch? It should add all the channels it finds instead of only the last one.

The reason for the "#" is to avoid conflicts when you rename the channels with proper names, so that won't change. In LiveTV hit "E" and it will bring up the frontend channel editor where you can rename the channel while watching it.

comment:4 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [10475]) Refs #1966. Fixes #2032. Fix insertion of pure MPEG channels when ATSC and DVB scanning fails.

Note: See TracTickets for help on using tickets.