Opened 13 years ago

Closed 12 years ago

#2036 closed defect (fixed)

MythWeb channel selection not filtering 'similar' channels

Reported by: knowledgejunkie@… Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: mythweb Version: head
Severity: medium Keywords: mythweb channel listings
Cc: Ticket locked: no

Description

(I've mailed both -users and -dev and not had a reply to either post). I'm running SVN 10424.

As I understand it, channels on different sources with identical 'channum' and 'callsign' are considered identical for display (I know there is a -dev thread regarding channel matching behaviour (http://www.gossamer-threads.com/lists/mythtv/dev/212014). I have also checked ticket #1964 which seems related but not the same observed issue.

When viewing listings in MythWeb, the above behaviour is observed and I only see one copy of such channels. However, if I drill-down to view the lineup for a particular channel, the channel selection drop down list contains _all_ visible channels, even those with identical channum and callsign. On my 2 sources I estimate there are 50% more channels in the list than need be.

I'm sorry if this is still not considered a defect and I've created the ticket in error - I would expect the behaviour of channel listings/selection to be consistent.

Nick

Attachments (1)

2306_patch.diff (540 bytes) - added by Jeff S. <jeff@…> 12 years ago.
Patch to fix duplicate channels (same callsign, same channum) from showing up

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by xris

Dupe of #1964 (well, both are caused by the same bug)

comment:2 Changed 13 years ago by xris

Resolution: duplicate
Status: newclosed

comment:3 Changed 12 years ago by Nick Morrott <knowledgejunkie@…>

Resolution: duplicate
Status: closedreopened
Version: head

I've re-opened this ticket after Janne's reply to my re-opening of the closely-related ticket #1964. I'm running 13242.

The channel dropdown list on the channel listing page still contains all copies of channels carrying the same station (with identical channum, callsign and listings data). This behaviour has not changed after the recent channel grouping updates in MythWeb.

I'm still certain that the current implementation for the channel droplist is not the intended behaviour for users with stations being carried across multiple videosources.

Where channels are configured with the same channum, callsign and listings data the channels are considered the same for scheduling purposes, and there is no benefit for listing them more than once in the droplist.

comment:4 Changed 12 years ago by Jeff S. <jeff@…>

This ticket is somewhat related to the ticket I submitted yesterday (ticket #3654). I've attached a patch to this ticket that should fix the problem. I've tested it using the described circumstances and it seems to work well.

Changed 12 years ago by Jeff S. <jeff@…>

Attachment: 2306_patch.diff added

Patch to fix duplicate channels (same callsign, same channum) from showing up

comment:5 Changed 12 years ago by Nick Morrott <<knowledgejunkie [at] gmail [dot] com>>

The patch from Jeff seems to have done the trick. The only question I now have is whether there is any potential issue with which video source provides each entry in the channel list?

My channels have priorities assigned by their video source, so that the channels on higher quality video sources (DVB-T for instance) have higher priority than those recorded by a lower quality source (my ivtv cards).

As the patch is not preferentially selecting the 'best' channels, the listings data from the lower quality video source can be displayed (although on my system common channels across video source share the same listings data).

As the scheduler determines which card to use at record time - and thus will prefer a higher priority channel if available, this is probably an irrelevance, but I just wanted to raise the issue in case there could be any side effects when creating a recording rule using the listings information from the lower priority channel.

Thanks again Jeff, Nick

comment:6 Changed 12 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: reopenednew

comment:7 Changed 12 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [14838]) Fixes #2036, this applys a patch from Jeff S to remove dup channels from the channel drop down list. I can not verify myself, but seems safe enough

Note: See TracTickets for help on using tickets.