Opened 14 years ago

Closed 14 years ago

#205 closed patch (duplicate)

Minor mtd cleanup patch

Reported by: Anduin Withers <awithers@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythdvd Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

  • several things that were members and didn't need to be
  • a few headers that didn't need to be included as soon as they were
  • made the handle/mutex cleanup stuff more automatic

Attachments (2)

mtd_cleanup.patch (17.0 KB) - added by Anduin Withers <awithers@…> 14 years ago.
mtd_cleanup2.patch (17.6 KB) - added by Anduin Withers <awithers@…> 14 years ago.
Better version

Download all attachments as: .zip

Change History (8)

Changed 14 years ago by Anduin Withers <awithers@…>

Attachment: mtd_cleanup.patch added

comment:1 Changed 14 years ago by Anduin Withers <awithers@…>

Component: mythtvmythdvd

Changed 14 years ago by Anduin Withers <awithers@…>

Attachment: mtd_cleanup2.patch added

Better version

comment:2 Changed 14 years ago by Isaac Richards

Please use QMutexLocker.

comment:3 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [7074]) Anduin's patch to cleanup the mtd a bit. Closes #205.

comment:4 Changed 14 years ago by anonymous

Resolution: fixed
Status: closedreopened

Patch needs to have some work done on it w.r.t the mutex handling.

comment:5 Changed 14 years ago by anonymous

Reference ticket #296 for the backtrace.

comment:6 Changed 14 years ago by danielk

Resolution: duplicate
Status: reopenedclosed

Duplicate of #296.

Note: See TracTickets for help on using tickets.