Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2061 closed defect (fixed)

Enable MPEG4 idct/ime recording profile settings

Reported by: gnome42@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Patch to enable the mpeg4optionidct and mpeg4optionime options that weren't being used by NVR. NOTE: Using these options requires significantly more CPU during MPEG4 encoding.

Attachments (1)

NVR_mpeg4_enable_idct_ime.diff (510 bytes) - added by gnome42@… 13 years ago.
Enable MPEG4 idct/ime

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by gnome42@…

Enable MPEG4 idct/ime

comment:1 Changed 13 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [10580]) Fix the nuv recorder to honor the mpeg4optionidct and mpeg4optionime options which are in the recording profile.

Closes #2061 using patch by gnome42.

comment:2 Changed 13 years ago by stuartm

(In [11063]) Refs #2061

Turn off the mpeg4optionidct and mpeg4optionime options. Both these options require a large amount of processing power. They may have been enabled by users in 0.19 before the settings were actually honoured.

Added a warning about the high cpu usage to the help text for these settings.

comment:3 Changed 13 years ago by bjm

(In [11064]) Update the help text for mpeg4optionidct and mpeg4optionime options. The real problem is that the code is not processing the data properly and can cause damaged video regardless of CPU usage. These damaged artifacts can be seen at low resolution when the CPU is not even close to being pegged (in fact, the high CPU may be a symptom of the problems while mis-handling the data).

What the user needs to know is that if they turn these on then see damaged recordings (for whatever reason) they should turn these off again as they are almost surely the cause of any new problems.

Because these option flags didn't work in previous versions, I agree that resetting them in dbcheck is a non-intrusive, good solution to prevent new complaints with 0.20.

Refs #2061

Note: See TracTickets for help on using tickets.