Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2068 closed defect (fixed)

DBox2: DB entries for the capture card get created inproperly

Reported by: hansi.urpils@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi there.

I tried to use my DBox2 as a capture card within MythTV. However, after going through all the steps in mythtv-setup, i get the following message when starting mythbackend:

2006-07-18 13:40:26.482 TVRec(1) Error: Start channel invalid, setting to '1' on input MPEG2TS instead.
[..]
2006-07-18 13:40:26.516 TVRec(1) Error: Setting start channel '1' failed,
                        and backup '1' failed as well.

I'm sure that this channel is there, my input connections look fine, too, that's why I decided to take a look at the database:

mysql> select inputname from cardinput;
+-----------+
| inputname |
+-----------+
| MPEG2TS   |
+-----------+
mysql> select defaultinput from capturecard;
+--------------+
| defaultinput |
+--------------+
| Television   |
+--------------+

I believe that this is the issue. I cannot tell mythtv-setup which input to use for the Dbox2, it just chooses "Television". Since there is no Television input available in the 'cardinput' table, it will just fail with the error message posted above - at least that's what I think.

I set the defaultinput to MPEG2TS then to test if that'd make it work. The error message about being unable to set the channel is gone, but it'll segfault. Occasionally, i can even see the DBox2Rec change the channel before it'll barf out:

2006-07-17 19:48:46.799 Main::Starting HttpServer
2006-07-17 19:48:46.810 Main::Registering HttpStatus Extension
2006-07-17 19:48:46.827 mythbackend version: 0.19.20060708-1 www.mythtv.org
2006-07-17 19:48:46.828 Enabled verbose msgs:  important general
2006-07-17 19:48:46.829 AutoExpire: Found 1 recorders w/max rate of 72 MiB/min
2006-07-17 19:48:46.834 AutoExpire: Required Free Space: 1.1 GB w/freq: 10 min
2006-07-17 19:48:47.041 DBox2Rec(135703736): Channel changing. Closing current stream...
2006-07-17 19:48:47.062 DBox2Rec(135703736): Channel changed. Requesting streams...
Segmentation fault

So it looks like changing defaultinput does indeed help, but I can't verify if this is the right thing to do because of the crash which is probably even caused by me messing with the DB.

I was going to open a new ticket for that crash in case it's not related. I'd appreciate any advice on how i should proceed from here on.

Anyways, it'd be cool if the DB issue could get fixed before 0.20 is released.

-- Michael

Change History (2)

comment:1 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [10586]) Fixes #2068. Set default input for DBOX2 recorders.

comment:2 Changed 13 years ago by danielk

Michael, open another ticket for the segfault with a backtrace attached. See the TicketHowTo. The DBox2 recorder is not actively maintained and none of the core developers use it, so any help you can provide is appreciated.

Note: See TracTickets for help on using tickets.