Opened 13 years ago

Closed 13 years ago

#2083 closed defect (duplicate)

mythtranscode --mpeg2: Deadlock detected. One buffer is full when the other is empty!

Reported by: hansi.urpils@… Owned by: Geoffrey Hausheer
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi there!

I'm trying to transcode (mythtranscode --mpeg2) a show that was recorded from a DBox2. It'll fail with a "Deadlock detected. One buffer is full when the other is empty! Aborting" error.

laga@peacekeeper:~/mythtranscode-bugreport$ mythtranscode --mpeg2 -i 1071_20060320232300.mpg
2006-07-22 01:29:11.508 Using runtime prefix = /usr/local
2006-07-22 01:29:12.304 DBPassword is not set in mysql.txt
2006-07-22 01:29:12.789 New DB connection, total: 1
2006-07-22 01:29:12.998 Enabled verbose msgs: important
2006-07-22 01:29:13.117 Couldn't find a recording on channel 1071 starting at Mo M� 20 23:23:00 2006 in the database.
2006-07-22 01:29:13.265 Parser not found for Codec Id: 94211 !
Mux rate: 15.64 Mbit/s
2006-07-22 01:34:47.962 Deadlock detected.  One buffer is full when
                the other is empty!  Aborting
laga@peacekeeper:~/mythtranscode-bugreport$ ls -al *mpg*
-rw-r--r-- 1 laga laga 2746222408 2006-07-19 00:37 1071_20060320232300.mpg
-rw-r--r-- 1 laga laga 2236082176 2006-07-22 01:34 1071_20060320232300.mpg.tmp

I've created a logfile with -v all, but it was over 130mb so I didn't want to attach it here. You can get a bzip2'ed version at http://serve.mythwiki.de/mythtranscode-bugreport-20060719/mythtranscode.log.bz2 (11mb).

Please let me know if additional information is needed. I could also upload this recording, but keep in mind that it'll take some time because my internet connection is rather slow.

-- Michael

Note: This might be a duplicate of #2077

Change History (1)

comment:1 Changed 13 years ago by Isaac Richards

Resolution: duplicate
Status: newclosed

Dupe of #2077.

Note: See TracTickets for help on using tickets.